summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-10-01 00:10:29 +0200
committerLouis Sautier <sbraz@gentoo.org>2023-10-01 00:10:29 +0200
commit6c3a619969a9eaec069974aae2074307502aa157 (patch)
tree397df1232b7a6c2224eb93f75f0eecb86bce73bd
parentnet-im/skypeforlinux: add 8.105.0.208 (diff)
downloadgentoo-6c3a619969a9eaec069974aae2074307502aa157.tar.gz
gentoo-6c3a619969a9eaec069974aae2074307502aa157.tar.bz2
gentoo-6c3a619969a9eaec069974aae2074307502aa157.zip
dev-python/denonavr: add 0.11.4
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-0.11.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index 024b1e6daab2..aaf8951a9763 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1 +1,2 @@
DIST denonavr-0.11.3.tar.gz 179597 BLAKE2B 139cda38958e320d72f11ef25e94db67346b7e9f253cbbf60a0cc5f5e2e42846f070a57cfb1596cb648d1d70a62983d8f5fe6b91aec5b95501c049c1c65b7141 SHA512 a361ac3dd6385ad7c042f6cb7bd2092c39da75c167277347d199ab9de3a1ef9fad84e41428cfa02058c680c905965214e42780fa4d4fb1f4a1116102284fe571
+DIST denonavr-0.11.4.tar.gz 179759 BLAKE2B c75b5679c614f3776afd8a24befb49ca5c2528cb6cd6a573ea221cc66e7b9ec9819770b646c52c0aed126b35733aab09a9eb7c5f673a8e3208507d0afda36117 SHA512 7bdae172034122cc55571dd83888091987c973e29fd0f881428d09c093510c99f4c6eceaab0868d024a2e6acca36eaa941d62332849e7dc2547a88111d8dc55a
diff --git a/dev-python/denonavr/denonavr-0.11.4.ebuild b/dev-python/denonavr/denonavr-0.11.4.ebuild
new file mode 100644
index 000000000000..5adf44a85b90
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.11.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.1[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest