summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-02-18 08:14:45 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-02-18 09:08:15 +0000
commit6c94a31847870f809ae0550ad816e64cb83523fa (patch)
tree9ec79425396d2cba156d8feca1b0d56a77eccc5d
parentapp-misc/ca-certificates: Bump to version 20190110.3.42.1 (diff)
downloadgentoo-6c94a31847870f809ae0550ad816e64cb83523fa.tar.gz
gentoo-6c94a31847870f809ae0550ad816e64cb83523fa.tar.bz2
gentoo-6c94a31847870f809ae0550ad816e64cb83523fa.zip
dev-lang/jimtcl: drop live ebuild
live ebuild is broken since around Dec 25 2017, commit 3499242f0065. inherits were switched to git-r3, but git-2 helpers are used directly. Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
deleted file mode 100644
index cd5797414a60..000000000000
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit eutils
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/msteveb/jimtcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~sh ~x86"
-fi
-
-DESCRIPTION="Small footprint implementation of Tcl programming language"
-HOMEPAGE="http://jim.tcl.tk/"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="doc static-libs"
-
-RDEPEND=""
-DEPEND="doc? ( app-text/asciidoc )
- app-arch/unzip"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
- else
- default
- fi
-}
-
-src_configure() {
- CCACHE=None econf --with-jim-shared
- if use static-libs ; then
- # The build does not support doing both simultaneously.
- mkdir static-libs || die
- cd static-libs || die
- CCACHE=None ECONF_SOURCE=${S} econf
- fi
-}
-
-src_compile() {
- # Must build static-libs first.
- use static-libs && emake -C static-libs libjim.a
- emake all
- use doc && emake docs
-}
-
-src_install() {
- dobin jimsh
- use static-libs && dolib.a static-libs/libjim.a
- ln -sf libjim.so.* libjim.so || die
- dolib.so libjim.so*
- insinto /usr/include
- doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h \
- jim-win32compat.h jim-eventloop.h jim-config.h
- dodoc AUTHORS README TODO
- dodoc Tcl.html
-}