summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-06-19 15:50:37 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-06-19 15:54:02 -0400
commit6ce05dd6b231bcd06f833fb0449eab39b11fce1e (patch)
treeabc5127219ea04a4f8865b651a9483cb98a4a450
parentapp-admin/ara: new package. (diff)
downloadgentoo-6ce05dd6b231bcd06f833fb0449eab39b11fce1e.tar.gz
gentoo-6ce05dd6b231bcd06f833fb0449eab39b11fce1e.tar.bz2
gentoo-6ce05dd6b231bcd06f833fb0449eab39b11fce1e.zip
sys-apps/memtest86+: install to /usr/share/${PN}
make the files available without forcing mount of /boot, mostly for the purposes of catalyst. committed with permission of floppym Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--sys-apps/memtest86+/memtest86+-5.01-r4.ebuild (renamed from sys-apps/memtest86+/memtest86+-5.01-r3.ebuild)66
-rw-r--r--sys-apps/memtest86+/metadata.xml3
2 files changed, 47 insertions, 22 deletions
diff --git a/sys-apps/memtest86+/memtest86+-5.01-r3.ebuild b/sys-apps/memtest86+/memtest86+-5.01-r4.ebuild
index 54b1ab6e21dc..e9528e637a87 100644
--- a/sys-apps/memtest86+/memtest86+-5.01-r3.ebuild
+++ b/sys-apps/memtest86+/memtest86+-5.01-r4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit mount-boot eutils toolchain-funcs
@@ -12,15 +12,19 @@ SRC_URI="http://www.memtest.org/download/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE="floppy iso serial"
+IUSE="+boot floppy iso serial"
BOOTDIR="/boot/memtest86plus"
-QA_PRESTRIPPED="${BOOTDIR}/memtest"
-QA_FLAGS_IGNORED="${BOOTDIR}/memtest"
+QA_PRESTRIPPED="${BOOTDIR}/memtest /usr/share/${PN}/memtest"
+QA_FLAGS_IGNORED="${BOOTDIR}/memtest /usr/share/${PN}/memtest"
RDEPEND="floppy? ( >=sys-boot/grub-0.95:0 sys-fs/mtools )"
DEPEND="iso? ( app-cdr/cdrtools )"
+pkg_pretend() {
+ use boot && mount-boot_pkg_pretend
+}
+
src_prepare() {
sed -i -e 's,0x10000,0x100000,' memtest.lds || die
epatch "${FILESDIR}/${P}-gcc-473.patch" \
@@ -39,6 +43,7 @@ src_prepare() {
config.h \
|| die "sed failed"
fi
+ default
}
src_configure() {
@@ -56,7 +61,12 @@ src_compile() {
src_test() { :; }
src_install() {
- insinto "${BOOTDIR}"
+ if use boot; then
+ insinto "${BOOTDIR}"
+ doins memtest memtest.bin
+ fi
+
+ insinto /usr/share/${PN}
use iso && newins mt*.iso memtest.iso
doins memtest memtest.bin
@@ -71,20 +81,34 @@ src_install() {
fi
}
+pkg_preinst() {
+ use boot && mount-boot_pkg_preinst
+}
+
pkg_postinst() {
- mount-boot_pkg_postinst
-
- elog "memtest86+ has been installed in ${BOOTDIR}/"
- elog "You may wish to update your bootloader configs by adding these lines:"
- elog " - For grub2 just run grub-mkconfig, a configuration file is installed"
- elog " as /etc/grub.d/39_${PN}"
- elog " - For grub legacy: (replace '?' with correct numbers for your boot partition)"
- elog " > title=${PN}"
- elog " > root (hd?,?)"
- elog " > kernel ${BOOTDIR}/memtest.bin"
- elog " - For lilo:"
- elog " > image = ${BOOTDIR}/memtest.bin"
- elog " > label = ${PN}"
- elog ""
- elog "Note: For older configs, you might have to change from 'memtest' to 'memtest.bin'."
+ if use boot; then
+ mount-boot_pkg_postinst
+
+ elog "memtest86+ has been installed in ${BOOTDIR}/"
+ elog "You may wish to update your bootloader configs by adding these lines:"
+ elog " - For grub2 just run grub-mkconfig, a configuration file is installed"
+ elog " as /etc/grub.d/39_${PN}"
+ elog " - For grub legacy: (replace '?' with correct numbers for your boot partition)"
+ elog " > title=${PN}"
+ elog " > root (hd?,?)"
+ elog " > kernel ${BOOTDIR}/memtest.bin"
+ elog " - For lilo:"
+ elog " > image = ${BOOTDIR}/memtest.bin"
+ elog " > label = ${PN}"
+ elog ""
+ elog "Note: For older configs, you might have to change from 'memtest' to 'memtest.bin'."
+ fi
+}
+
+pkg_prerm() {
+ use boot && mount-boot_pkg_prerm
+}
+
+pkg_postrm() {
+ use boot && mount-boot_pkg_postrm
}
diff --git a/sys-apps/memtest86+/metadata.xml b/sys-apps/memtest86+/metadata.xml
index fc17238d1174..1745d86466f6 100644
--- a/sys-apps/memtest86+/metadata.xml
+++ b/sys-apps/memtest86+/metadata.xml
@@ -6,8 +6,9 @@
<name>Gentoo Base System</name>
</maintainer>
<use>
- <flag name="serial">Compile with serial console support</flag>
+ <flag name="boot">Also install to /boot instead of just /usr/share/memtest86+/</flag>
<flag name="floppy">Install a script to create floppy disks containing memtest86+ binaries.</flag>
<flag name="iso">Compile an ISO image</flag>
+ <flag name="serial">Compile with serial console support</flag>
</use>
</pkgmetadata>