summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-11 12:19:14 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-11 12:32:17 +0100
commit6d0c00f1fb7b928b16c17ffc426264591fadec47 (patch)
tree9557088da36a0eb7b73a91f59af9d1c5ffbfe5ed
parentvirtual/python-dnspython: Stable under ALLARCHES policy (diff)
downloadgentoo-6d0c00f1fb7b928b16c17ffc426264591fadec47.tar.gz
gentoo-6d0c00f1fb7b928b16c17ffc426264591fadec47.tar.bz2
gentoo-6d0c00f1fb7b928b16c17ffc426264591fadec47.zip
dev-python/twill: Use python2 for doc building
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/twill/twill-0.9-r1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/twill/twill-0.9-r1.ebuild b/dev-python/twill/twill-0.9-r1.ebuild
index 3c54b5d90643..8133d6c41466 100644
--- a/dev-python/twill/twill-0.9-r1.ebuild
+++ b/dev-python/twill/twill-0.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,20 +20,24 @@ SLOT="0"
KEYWORDS="amd64 ~arm ppc ~ppc64 x86"
IUSE="doc examples"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
- $(python_gen_cond_dep 'dev-python/epydoc[${PYTHON_USEDEP}]' python2_7)
- || (
- dev-python/dnspython:0[${PYTHON_USEDEP}]
- virtual/python-dnspython:0[${PYTHON_USEDEP}]
- )
+ $(python_gen_cond_dep 'dev-python/epydoc[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'virtual/python-dnspython[${PYTHON_USEDEP}]' 'python2*')
)"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_compile_all() {
if use doc; then
+ python_setup 'python2*'
pushd doc > /dev/null || die
chmod +x make-epydoc.sh || die
./make-epydoc.sh || die