summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-24 00:04:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-24 00:04:05 +0200
commit6d3b325ef8986e1a85314af5a3d54950b47d9c73 (patch)
tree23dbfc4bf1fb8867a89ab1cdff29ca537cc0a6c6
parentx11-wm/icewm: Removed old. (diff)
downloadgentoo-6d3b325ef8986e1a85314af5a3d54950b47d9c73.tar.gz
gentoo-6d3b325ef8986e1a85314af5a3d54950b47d9c73.tar.bz2
gentoo-6d3b325ef8986e1a85314af5a3d54950b47d9c73.zip
net-print/cups-filters: Bump to version 1.25.3
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.25.3.ebuild134
2 files changed, 135 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index fceda716b8bb..ab56c6545c69 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -4,3 +4,4 @@ DIST cups-filters-1.23.0.tar.xz 1477900 BLAKE2B 00a67ace059c9c280dbd4019fbfec61e
DIST cups-filters-1.25.0.tar.xz 1447496 BLAKE2B 297f16a5580787ccf1494ae99a90ed5912156e255394e3d3e921d8e29db9f94b0ed8409b641bec5231dfc0c802b773415beaf4103424cc2cb46d25d9f3804d8e SHA512 f1be31721fd8f6192868e7954d94038ff1382bb0194bb64014da3dd695cbbd2cd5d65373d809e1b541071374b7eabb44c68c6be29575251490d76a0a5336a5c5
DIST cups-filters-1.25.1.tar.xz 1447208 BLAKE2B ccc9e02309b7a29ac79f91b1de92e11d78ee108777af0e07127f15ba64c6fece79482bf00011e2f82f50eb2bdea42f4a94f4d591402b35757b62876b04119fe5 SHA512 474045497237387dd16bde73253d9e4e9e0ca2f33f3f7ff70245b4c0f8b1dc71abe141f8ab6b467d941dd7153e11369951bc778ef677d6ea17101cd91886625c
DIST cups-filters-1.25.2.tar.xz 1449984 BLAKE2B a6f595ac2c1ef55302aa9063d88d77ff518d1b32cd74449a28e039caa119f894577ed79c312b96181b12ae5153859685ba3f95e250f87c9f2ab002279153fd15 SHA512 e616a3a356ea7ad7d61e50242c1c0fd899911a8a293e721a89b425fb6a5d6d98388bbd4c02df407d9b66219b99f7c41a457b1436af6b9d8e979f0fd4e392ef3e
+DIST cups-filters-1.25.3.tar.xz 1448840 BLAKE2B d58d93995d1742ceea861896399687717b7791ef6208daaf50e6df715943ac7c5a8709ad93b5d0c66e412ae4832b1969b238f277bdefb1da61b00dd0cb984fc9 SHA512 df3c5fc9e4e0449943abbff19a537057f9def3a18504241581727ed6a39ecad30315d5593bdf31d04d51181dd402a418805185afa15c22dabf34e1e9eea90a81
diff --git a/net-print/cups-filters/cups-filters-1.25.3.ebuild b/net-print/cups-filters/cups-filters-1.25.3.ebuild
new file mode 100644
index 000000000000..cdc922f82de3
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.25.3.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RDEPEND="
+ >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+ >=app-text/qpdf-8.3.0:=
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( virtual/jpeg:0 )
+ ldap? ( net-nds/openldap )
+ pdf? ( app-text/mupdf )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:0= )
+ postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+ tiff? ( media-libs/tiff:0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+ default
+ [[ "${PV}" == "9999" ]] && eautoreconf
+
+ # Bug #626800
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-imagefilters
+ --localstatedir="${EPREFIX}"/var
+ --with-browseremoteprotocols=DNSSD,CUPS
+ --with-cups-rundir="${EPREFIX}"/run/cups
+ --with-fontdir="fonts/conf.avail"
+ --with-pdftops=pdftops
+ --with-rcdir=no
+ --without-php
+ $(use_enable dbus)
+ $(use_enable foomatic)
+ $(use_enable ipp_autosetup auto-setup-driverless)
+ $(use_enable ldap)
+ $(use_enable pclm)
+ $(use_enable pdf mutool)
+ $(use_enable postscript ghostscript)
+ $(use_enable static-libs static)
+ $(use_enable zeroconf avahi)
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with tiff)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_configure
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null
+ fi
+
+ if use postscript; then
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym gstopxl /usr/libexec/cups/filter/pstopxl
+ fi
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+ emake check
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+ ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+ fi
+}