summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-12-21 12:38:49 +0100
committerCraig Andrews <candrews@gentoo.org>2020-12-21 07:55:33 -0500
commit6d78d5b859d4737d2dc7b70cdca781db04350a9c (patch)
treeaaca0b156e1258b6924c43b9388f0f55ad9d1b52
parentdev-lang/rust: use ED in removal operations. (diff)
downloadgentoo-6d78d5b859d4737d2dc7b70cdca781db04350a9c.tar.gz
gentoo-6d78d5b859d4737d2dc7b70cdca781db04350a9c.tar.bz2
gentoo-6d78d5b859d4737d2dc7b70cdca781db04350a9c.zip
dev-libs/roct-thunk-interface: Version bump to 4.0.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.9, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18745 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/roct-thunk-interface/Manifest1
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-4.0.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/roct-thunk-interface/Manifest b/dev-libs/roct-thunk-interface/Manifest
index 676a4a452ee4..624426cb0b6f 100644
--- a/dev-libs/roct-thunk-interface/Manifest
+++ b/dev-libs/roct-thunk-interface/Manifest
@@ -2,3 +2,4 @@ DIST roct-thunk-interface-3.10.0.tar.gz 2694321 BLAKE2B c743e2df8133a382f62f0cac
DIST roct-thunk-interface-3.7.0.tar.gz 2692297 BLAKE2B 5a060becb1b35e4eb499de5c177b5747789f02036d6e1bbf241a4054430e819bab4c188aa83f1cec0d35c80a3c0af47298fdd1c34d272f693dac9da191d8d111 SHA512 307e88808d3c852837f81c8745181edaa46e0f205fa36b9af531661c9a6a2dee5f360eb14e9f607376f27969e438f075dd44336606803ae2f7ce597f7fe46135
DIST roct-thunk-interface-3.8.0.tar.gz 2692624 BLAKE2B bb0d288da08081de63f3848987eb86a319c977250052b8bcccdd221b31167d2b344ecd17163aafe1fa5e7a4372248510af77c4ed992c39e71de05452b0b83a8c SHA512 b60461869f916791b702fb7a551978dd741873925154cb5980612f71bb19000f73fda8c1becb5e3482be872790d6cc8c34dfe3484349796c9fab2fedafef525b
DIST roct-thunk-interface-3.9.0.tar.gz 2692605 BLAKE2B e256217aa8410eb3a1cbb430509c7426e2b00f4ad0a0a3d14879fc116a112e9d10e50b0e2d336f04bc52d98f0d98afda5195565995c6d8b64101132e9c71746c SHA512 eb0d3abaae1aa92f60eeb58ef07bf6dd0f954488e2e05bcf30cb75aa772430c49a3103b0498208c7f8f8fd35fb5d91f0f8c056064ce595263e1737e8f72ba462
+DIST roct-thunk-interface-4.0.0.tar.gz 2694100 BLAKE2B 49ca128902335fc36d44b9e71d444a467bdd0b39ce0b487c70f1f68180fb4b564b10a65e26e41b71d5e66721c3086ec834aee2550246172965f2d611ce9a644a SHA512 cbb45c4372ce2620fce6ccbf94e8e7600256d12acf6721da9d22aeb619cec9d4e4e25354649b83fb322f8d369347c251ebb7242ff8fc3976cc3983de0d8e30a9
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-4.0.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-4.0.0.ebuild
new file mode 100644
index 000000000000..ee5be506ed83
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-4.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake linux-info
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCT-Thunk-Interface-rocm-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Thunk Interface"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface"
+CONFIG_CHECK="~HSA_AMD ~HMM_MIRROR ~ZONE_DEVICE ~DRM_AMDGPU ~DRM_AMDGPU_USERPTR"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="sys-process/numactl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ cmake_src_prepare
+}
+src_configure() {
+ local mycmakeargs=(
+ -DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+ cmake_src_configure
+}