summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-18 18:40:31 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-18 18:54:15 -0600
commit6e363cc3d78757fe25fff31700d4a1c5f62e34c6 (patch)
treefab3c660745fb9e335883e7f9b88560312f1cbff
parentdev-python/os-brick: 2.3.0 bup (diff)
downloadgentoo-6e363cc3d78757fe25fff31700d4a1c5f62e34c6.tar.gz
gentoo-6e363cc3d78757fe25fff31700d4a1c5f62e34c6.tar.bz2
gentoo-6e363cc3d78757fe25fff31700d4a1c5f62e34c6.zip
dev-python/python-cinderclient: 3.5.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/python-cinderclient/Manifest1
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-3.5.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index 0a685e5361a6..574ed379fe93 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -2,3 +2,4 @@ DIST python-cinderclient-1.11.0.tar.gz 239521 BLAKE2B 108a6ce33427b84e7b367091bd
DIST python-cinderclient-1.6.0.tar.gz 194134 BLAKE2B 362bb699f4285da983f61ff44e9c4b666f7bb1943673d48480aecb2edd78d86619913420287b8b2f01403d5e8bed10dbdca0e44f41d075b7186f7313d1ee56b5 SHA512 421c665be2d410f511c751687df438dc268c4d2ae5ca83d8ee2d37d3b61cd08f718851c65338e14c8cbb8304703b5f9acf98611246ca6866c5a31cc3dd86e39b
DIST python-cinderclient-1.9.0.tar.gz 231331 BLAKE2B c9e42dafbb5bdde383da34e0b3bbf0a437e4851d6ba6267fb64f647840999ed5029d6a0f1690872cf85cb3af3a0b9b296d9f9414a705a4edc7503aa96394d0aa SHA512 be9c976ad9ef6005100f51bda75234253f9394aeda9ccc28f0b673bf39f5856fae2f23208e05057a58f2155d1b4fb728ec178b7fab21abca9eb88fe2ac82c018
DIST python-cinderclient-3.1.0.tar.gz 278247 BLAKE2B d5fb6b3f74c70fd58cdc8a2cf2ea7a57935fd3246de035ebfc84d1acb037ff309ff1de2954c373a453f623e78b6c84bfca194f77273420eaa46ee291a2a97c28 SHA512 6d828a96802d9a5118ab3b463ed9c8619530a69a1ca153f0c3d737e26bd692864ad2ba4c79e74a18ebf820222a75b81a9735f63c989817797689d8f399f76394
+DIST python-cinderclient-3.5.0.tar.gz 284317 BLAKE2B c231b2d67071dc01521e271cdae19d0e1bb8af387780b4f855631ae248e156110888eddd63684102d5b5769840d31e622d9db1e24ecdb90ddda06e803c6586fd SHA512 0ee11c19b404c5f335422a5a18d01529330dc8d39b58c5f8b6be28a0e682858f1fea5f21bfcfc2a272a556f1a3a61fa6a0379fadbe79b65a4ad72cccf42a6223
diff --git a/dev-python/python-cinderclient/python-cinderclient-3.5.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-3.5.0.ebuild
new file mode 100644
index 000000000000..39e006ff9189
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-3.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}