summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-11-11 14:24:16 +0100
committerPacho Ramos <pacho@gentoo.org>2021-11-11 14:52:06 +0100
commit6eb1d141a933edcf54ae5593c4840fd7049c10fb (patch)
treea1bb11db8850120e5a9341f681d9c4a2cc44fc50
parentdev-libs/libgnome-games-support: Bump to 1.8.2 (diff)
downloadgentoo-6eb1d141a933edcf54ae5593c4840fd7049c10fb.tar.gz
gentoo-6eb1d141a933edcf54ae5593c4840fd7049c10fb.tar.bz2
gentoo-6eb1d141a933edcf54ae5593c4840fd7049c10fb.zip
net-libs/libsoup: Bump to 2.74.1
Closes: https://bugs.gentoo.org/810883 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--net-libs/libsoup/Manifest1
-rw-r--r--net-libs/libsoup/libsoup-2.74.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/net-libs/libsoup/Manifest b/net-libs/libsoup/Manifest
index d629aa8d30b4..5bfb22929dec 100644
--- a/net-libs/libsoup/Manifest
+++ b/net-libs/libsoup/Manifest
@@ -1,3 +1,4 @@
DIST libsoup-2.72.0.tar.xz 1477940 BLAKE2B e63a26aa29a4a34c4e4b0a2713818db52b206b04b56d99391648351f87a62dc3455020e8eb0312ef17b2b7d047a7d5731905ecc214085afd4eff25fefa30782b SHA512 ca16772d0d318c4be0c4859db1e32baffa2231b4732f3bf9814aa405febde86395a0fb8bfa1635d70a7b5853d2567403920b9b0d0f5c3c179294352af27e91de
DIST libsoup-2.74.0.tar.xz 1498224 BLAKE2B c03b817a7a7f708480581aad258e5e24c541c6c2f39e48c51597d67c729b3a0722ef094916ad841904a0cafc67f12ad20d05b74ac41aeb174cb79b49fdd0977e SHA512 d78374c31631d7d1fb30ceb7c6016ab970cb321b06191d3463f178ceea9dacd08c828b8f16f5a30c185489ebfbc93ff9da09ae4978be3e3ff11bf7ee95a2a9a6
+DIST libsoup-2.74.1.tar.xz 1496188 BLAKE2B 6f15415d5d4d68fa1f7167363cbed77dee9d4feea226357389209c96367c27c554fdc81fa25bcc8ce02290d6781dc2cc99298342349aada9ad9e32a10727c641 SHA512 107726e069becc0a79904905a10a0ceb0c010fcae57ee86fbb838e6edf58abfc464c8e6c3afb610e495d9c2a24ec6b4ba4c023921611642a9d3c89627daa154b
DIST libsoup-2.99.9.tar.xz 1514372 BLAKE2B c7c708e477e38fa03d19e3a35eb99a6183774275ed0e2c00a1c62c238ca932e62aa71713386010b36a3c7aac1c78ebc3555635a2e2db4c68406e25510432db62 SHA512 77fff5c4d72bd5acad5b9b4a312cc999b960d6eb7e4715cdd2571859a0ee888988fee12bd46684ca948993a2308f10def1141fe3e3137ac9cce68190222ee858
diff --git a/net-libs/libsoup/libsoup-2.74.1.ebuild b/net-libs/libsoup/libsoup-2.74.1.ebuild
new file mode 100644
index 000000000000..5bf1131885f8
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.74.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson-multilib vala xdg
+
+DESCRIPTION="HTTP client/server library for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+
+# TODO: Default enable brotli at some point? But in 2.70.0 not advertised to servers yet - https://gitlab.gnome.org/GNOME/libsoup/issues/146
+IUSE="brotli gssapi gtk-doc +introspection samba ssl sysprof test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.58:2[${MULTILIB_USEDEP}]
+ >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+ brotli? ( >=app-arch/brotli-1.0.6-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ sys-libs/zlib
+ gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+ >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
+"
+BDEPEND="
+ dev-libs/glib
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.20
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+# dev-lang/php[apache2,xmlrpc]
+# net-misc/curl
+# net-libs/glib-networking[ssl])"
+
+PATCHES=(
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ "${FILESDIR}"/disable-apache-tests.patch
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+ # https://gitlab.gnome.org/GNOME/libsoup/issues/159 - could work with libnss-myhostname
+ sed -e '/hsts/d' -i tests/meson.build || die
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ # But necessary while apache tests are disabled
+ #addpredict /usr/share/snmp/mibs/.index
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature gssapi)
+ -Dkrb5_config="${CHOST}-krb5-config"
+ $(meson_feature samba ntlm)
+ $(meson_feature brotli)
+ -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
+ -Dtls_check=false # disables check, we still rdep on glib-networking
+ -Dgnome=false
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_feature vala vapi)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ $(meson_feature sysprof)
+ )
+ meson_src_configure
+}