summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2017-02-06 14:25:05 +0800
committerYixun Lan <dlan@gentoo.org>2017-02-06 14:26:16 +0800
commit6eefa78d5b87b6addb3610ef6357593af0432cbb (patch)
tree3776dfeed0da04ff3a846fd6d9715cbc9f0bdb8d
parentdev-python/psutil: Removed old. (diff)
downloadgentoo-6eefa78d5b87b6addb3610ef6357593af0432cbb.tar.gz
gentoo-6eefa78d5b87b6addb3610ef6357593af0432cbb.tar.bz2
gentoo-6eefa78d5b87b6addb3610ef6357593af0432cbb.zip
dev-util/vmtouch: version bump 1.2.0
Gentoo-Bug: 607098 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-util/vmtouch/Manifest1
-rw-r--r--dev-util/vmtouch/vmtouch-1.2.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/vmtouch/Manifest b/dev-util/vmtouch/Manifest
index ac26980b8cd8..21ed08f5a0e9 100644
--- a/dev-util/vmtouch/Manifest
+++ b/dev-util/vmtouch/Manifest
@@ -1 +1,2 @@
DIST vmtouch-1.0.2.tar.gz 13404 SHA256 48d41e5b805a0fcac46c12feeb4650e4b9def44b75d528d7c66c2f8b3a747c39 SHA512 df0d8a1599c970540e70e050dab33327589f0dd64548640c7d44607c3ef3397c7b1d2184fe80195ec5cb9a73d7218d7fd1b2cda2cee227ce84a8c20e8874f489 WHIRLPOOL 903813783d93395b637b565a887b8d0d3d5d3b7d548d9a98d49c1ab9bfc82322a495c771937cc7688561de30d0ec2aca6edb6d599508c440bd963547b78915b9
+DIST vmtouch-1.2.0.tar.gz 15993 SHA256 154034dec5ef550dcb7ff5a359ee1b7a9421f586f47237e3bc2617efa148b5fd SHA512 cc13688c1b8bee38495ed3b9295d0066e33f4242b6bb70c4547cb99c1403c15b71ae1c739a8f7dc718f760c40ff4e7ba3dd55691900b501305d9263797c3b5cd WHIRLPOOL 237243ccd97774896fe5178e4535bb09efa0a3369a3d337350d228d44415b348ff51a6f7d57f08ee5f6ee0f32c38f3eba99f2696081dcff5db817396deb0fb78
diff --git a/dev-util/vmtouch/vmtouch-1.2.0.ebuild b/dev-util/vmtouch/vmtouch-1.2.0.ebuild
new file mode 100644
index 000000000000..fdf230f6bac7
--- /dev/null
+++ b/dev-util/vmtouch/vmtouch-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Virtual Memory Toucher, portable file system cache diagnostics and control"
+HOMEPAGE="http://hoytech.com/vmtouch/"
+SRC_URI="https://github.com/hoytech/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local my_prefix="${ED}/usr"
+ emake PREFIX="${my_prefix}" MANDIR="${my_prefix}/share/man/man8" install
+ dodoc CHANGES README.md TODO
+}