summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-12-08 00:03:59 +0100
committerSebastian Pipping <sping@gentoo.org>2017-12-08 00:15:31 +0100
commit6ef22505bc25ef8a68bef36e38832c7207d7aa68 (patch)
tree7f14476ff4c2d862641e68943bbe7dc73b204bd3
parentapp-crypt/debian-archive-keyring: 2017.6 (diff)
downloadgentoo-6ef22505bc25ef8a68bef36e38832c7207d7aa68.tar.gz
gentoo-6ef22505bc25ef8a68bef36e38832c7207d7aa68.tar.bz2
gentoo-6ef22505bc25ef8a68bef36e38832c7207d7aa68.zip
dev-python/piexif: 1.0.13
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--dev-python/piexif/Manifest3
-rw-r--r--dev-python/piexif/piexif-1.0.13.ebuild26
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-python/piexif/Manifest b/dev-python/piexif/Manifest
index 7f9676188a59..80993f04a877 100644
--- a/dev-python/piexif/Manifest
+++ b/dev-python/piexif/Manifest
@@ -1 +1,2 @@
-DIST piexif-1.0.12.zip 1005725 SHA256 312e01e2113d0885088cf43704d8c7337fdb0144789a59b05ebaf7b24e6ebb95 SHA512 71de13b30d041c2de2136e9299bea96a0446352815de5358863324743aac6a5e187800214edd209dd212108ce9a0b0b4602aee54dd54f8b058228b255b543c63 WHIRLPOOL 6adc52a4551e55b70338fbba6c350864353bdaa55a10f225d3fde086f5232c4a9725a94db04695fd87b46662a91dba253aa3ccfa342b700a2e2974c0792affcb
+DIST piexif-1.0.12.zip 1005725 BLAKE2B ff370dfea7b2e3b0013c484c586a294ed3b1590f9248104927974b4f7d2b82435da8fb0d8345ac23bd724606e0cefc2594ba9fa49c58d0f4f00219c1a4ed6cce SHA512 71de13b30d041c2de2136e9299bea96a0446352815de5358863324743aac6a5e187800214edd209dd212108ce9a0b0b4602aee54dd54f8b058228b255b543c63
+DIST piexif-1.0.13.zip 1008345 BLAKE2B f2f1ba520d661bf3f50de41b81ceebdaff8db2d83f76d4202771438d78c30beabf118f5732a5e76a6484fbf2bd850b461a9d1a0b675f12995dd7f3c8bb32e6cf SHA512 4234783a639e777b58eb0b4591a272d7d5e8c116a7a242cf36287e64d15089478c88327a16b4fa75786fc3621a6bf647f6a075fab0708e2d0aed6395f95b92cb
diff --git a/dev-python/piexif/piexif-1.0.13.ebuild b/dev-python/piexif/piexif-1.0.13.ebuild
new file mode 100644
index 000000000000..1f3c4871b820
--- /dev/null
+++ b/dev-python/piexif/piexif-1.0.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.python.org/pypi/piexif"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow )"
+
+python_test() {
+ "${PYTHON}" setup.py test
+}