summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-03-25 19:10:19 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-26 17:45:19 +0100
commit6ff1aae28f02a921c39f5a204e54e434f55c7045 (patch)
treefa1c6ddb449bf326f0caf890452bdc620f68334f
parentnet-libs/xrootd: remove unused patch. (diff)
downloadgentoo-6ff1aae28f02a921c39f5a204e54e434f55c7045.tar.gz
gentoo-6ff1aae28f02a921c39f5a204e54e434f55c7045.tar.bz2
gentoo-6ff1aae28f02a921c39f5a204e54e434f55c7045.zip
app-misc/mosquitto: remove unused patches.
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11497 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-misc/mosquitto/files/mosquitto-1.4.10-conditional-tests.patch43
-rw-r--r--app-misc/mosquitto/files/mosquitto-1.5-fix-socket_get_address.patch29
-rw-r--r--app-misc/mosquitto/files/mosquitto-fix-conditional-tests.patch12
3 files changed, 0 insertions, 84 deletions
diff --git a/app-misc/mosquitto/files/mosquitto-1.4.10-conditional-tests.patch b/app-misc/mosquitto/files/mosquitto-1.4.10-conditional-tests.patch
deleted file mode 100644
index 12b4fc56bc3c..000000000000
--- a/app-misc/mosquitto/files/mosquitto-1.4.10-conditional-tests.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- a/test/broker/Makefile 2016-06-02 22:20:22.000000000 +0100
-+++ b/test/broker/Makefile 2016-07-08 14:17:33.772666865 +0100
-@@ -63,6 +63,7 @@
- ./05-clean-session-qos1.py
-
- 06 :
-+ifeq ($(WITH_BRIDGE),yes)
- ./06-bridge-reconnect-local-out.py
- ./06-bridge-br2b-disconnect-qos1.py
- ./06-bridge-br2b-disconnect-qos2.py
-@@ -70,6 +71,7 @@
- ./06-bridge-b2br-disconnect-qos2.py
- ./06-bridge-fail-persist-resend-qos1.py
- ./06-bridge-fail-persist-resend-qos2.py
-+endif
-
- 07 :
- ./07-will-qos0.py
-@@ -87,10 +89,12 @@
- ./08-ssl-connect-cert-auth-crl.py
- ./08-ssl-connect-identity.py
- ./08-ssl-connect-no-identity.py
-+ifeq ($(WITH_BRIDGE),yes)
- ./08-ssl-bridge.py
- ./08-tls-psk-pub.py
- ./08-tls-psk-bridge.py
- endif
-+endif
-
- 09 :
- ./09-plugin-auth-unpwd-success.py
---- a/test/broker/c/Makefile 2016-02-14 14:36:55.000000000 +0000
-+++ b/test/broker/c/Makefile 2016-05-05 09:40:31.440608209 +0100
-@@ -13,7 +13,9 @@
- $(CC) ${CFLAGS} $^ -o $@ ../../../lib/libmosquitto.so.1
-
- 08-tls-psk-bridge.test : 08-tls-psk-bridge.c
-+ifeq ($(WITH_BRIDGE),yes)
- $(CC) ${CFLAGS} $^ -o $@ ../../../lib/libmosquitto.so.1
-+endif
-
-
- reallyclean : clean
diff --git a/app-misc/mosquitto/files/mosquitto-1.5-fix-socket_get_address.patch b/app-misc/mosquitto/files/mosquitto-1.5-fix-socket_get_address.patch
deleted file mode 100644
index 7e9778e8b70f..000000000000
--- a/app-misc/mosquitto/files/mosquitto-1.5-fix-socket_get_address.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-# Fix missing rename of mosquitto__socket_get_address. Mosquitto bug 810.
-
-diff --git a/src/conf.c b/src/conf.c
-index f3d812d..daf2bf4 100644
---- a/src/conf.c
-+++ b/src/conf.c
-@@ -735,8 +735,8 @@ int config__read_file_core(struct mosquitto__config *config, bool reload, struct
- struct mosquitto__listener *cur_listener = &config->default_listener;
- #ifdef WITH_BRIDGE
- char *address;
-- int i;
- #endif
-+ int i;
- int lineno_ext;
- struct mosquitto__security_options *cur_security_options = NULL;
-
-diff --git a/src/net.c b/src/net.c
-index 7397de5..670b7e2 100644
---- a/src/net.c
-+++ b/src/net.c
-@@ -114,7 +114,7 @@ int net__socket_accept(struct mosquitto_db *db, mosq_sock_t listensock)
- fromhost(&wrap_req);
- if(!hosts_access(&wrap_req)){
- /* Access is denied */
-- if(!mosquitto__socket_get_address(new_sock, address, 1024)){
-+ if(!net__socket_get_address(new_sock, address, 1024)){
- log__printf(NULL, MOSQ_LOG_NOTICE, "Client connection from %s denied access by tcpd.", address);
- }
- COMPAT_CLOSE(new_sock);
diff --git a/app-misc/mosquitto/files/mosquitto-fix-conditional-tests.patch b/app-misc/mosquitto/files/mosquitto-fix-conditional-tests.patch
deleted file mode 100644
index 1642597c5620..000000000000
--- a/app-misc/mosquitto/files/mosquitto-fix-conditional-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/test/broker/c/Makefile 2016-02-14 14:36:55.000000000 +0000
-+++ b/test/broker/c/Makefile 2016-05-05 09:40:31.440608209 +0100
-@@ -13,7 +13,9 @@
- $(CC) ${CFLAGS} $^ -o $@ ../../../lib/libmosquitto.so.1
-
- 08-tls-psk-bridge.test : 08-tls-psk-bridge.c
-+ifeq ($(WITH_BRIDGE),yes)
- $(CC) ${CFLAGS} $^ -o $@ ../../../lib/libmosquitto.so.1
-+endif
-
-
- reallyclean : clean