summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-11 21:53:33 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-12 00:59:41 +0100
commit70f9d6596f89fcba5d097c2aaac2acd917925da0 (patch)
tree0ae9d3452db0ad363eaf56901d05fb420cd9da44
parentsys-kernel/vanilla-sources: Linux patches 4.8.14 and 4.4.38. Remove old (diff)
downloadgentoo-70f9d6596f89fcba5d097c2aaac2acd917925da0.tar.gz
gentoo-70f9d6596f89fcba5d097c2aaac2acd917925da0.tar.bz2
gentoo-70f9d6596f89fcba5d097c2aaac2acd917925da0.zip
sys-process/anacron: EAPI 6 bump and ebuild refresh.
Package-Manager: portage-2.3.0
-rw-r--r--sys-process/anacron/anacron-2.3-r4.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sys-process/anacron/anacron-2.3-r4.ebuild b/sys-process/anacron/anacron-2.3-r4.ebuild
new file mode 100644
index 000000000000..881462729575
--- /dev/null
+++ b/sys-process/anacron/anacron-2.3-r4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="a periodic command scheduler"
+HOMEPAGE="http://anacron.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-process/cronbase"
+
+RDEPEND="
+ ${DEPEND}
+ virtual/mta"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-compile-fix-from-debian.patch
+ "${FILESDIR}"/${P}-headers.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/{s:=:+=:;s:-O2::}' \
+ Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ # This does not work if the directory already exists.
+ diropts -m0750 -o root -g cron
+ keepdir "/var/spool/${PN}"
+
+ doman "${PN}tab.5" "${PN}.8"
+ newinitd "${FILESDIR}/${PN}.rc6" "${PN}"
+ dodoc ChangeLog README TODO
+ dosbin "${PN}"
+
+ insinto /etc
+ doins "${FILESDIR}/${PN}tab"
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Schedule the command \"anacron -s\" as a daily cron-job (preferably"
+ elog "at some early morning hour). This will make sure that jobs are run"
+ elog "when the systems is left running for a night."
+ echo
+ elog "Update /etc/anacrontab to include what you want anacron to run."
+
+ echo
+ elog "You may wish to read the Gentoo Linux Cron Guide, which can be"
+ elog "found online at:"
+ elog " https://wiki.gentoo.org/wiki/Cron"
+ fi
+}