summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxxim <fonic.maxxim@live.com>2017-12-18 01:07:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-18 02:28:23 +0100
commit7142e5e9bb52a70b83dbe109f733fa66deb08575 (patch)
tree60076000ee9b40f1fbee86756f9a0d72e643c574
parentapp-admin/cancd: modernize the service script and ebuild. (diff)
downloadgentoo-7142e5e9bb52a70b83dbe109f733fa66deb08575.tar.gz
gentoo-7142e5e9bb52a70b83dbe109f733fa66deb08575.tar.bz2
gentoo-7142e5e9bb52a70b83dbe109f733fa66deb08575.zip
net-misc/teamviewer: 13.0.5693 version bump (non-maintainer commit)
Committer comment: Tidied up - trivial comments - unnecessary empty lines - unquoted vars - whitespace - re-grouped pkg_postinst elog Tested-by: Cănărău Constantin <canarauc@yahoo.com> Bug: https://bugs.gentoo.org/621818 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--net-misc/teamviewer/Manifest2
-rw-r--r--net-misc/teamviewer/files/teamviewerd13.init8
-rw-r--r--net-misc/teamviewer/teamviewer-13.0.5693.ebuild123
3 files changed, 133 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index bfe23d2978dc..e4c120f019d1 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -2,3 +2,5 @@ DIST teamviewer-9.0.32150.deb 22898922 BLAKE2B 799aa6f48b69247a2695ca745e85d02ff
DIST teamviewer_10.0.46203_i386.deb 43326592 BLAKE2B 874bad1cf2efdb7f4c1da69a625549b2c46e6a710ca3cf871dd21fd804b1b1b8294981d8f6e27c58231e51e41fb0dcd8f42f08adcefc4e2ded61c15fdc068425 SHA512 2133194b180648685a9e179df1a2888277f3038d9098d0d12b72de92026bdb969d90262514996df60dfcf6986e291ecb756fde9e0781fca5c872b5c82e5494ea
DIST teamviewer_11.0.67687_i386.deb 47341822 BLAKE2B 3aa7d9af2c0c39fad22cec8391921d1034e2dc4bab70f9fb04c7dd7a9a8c23ae484717b3cf71856734bec08a26b4f409c205dde2b9b511b6d0fe78dc6182dc75 SHA512 3fbb0a2fc1bccd41ba9798305fada7e8266e1c9ed8509492ccb75e6f85995538ddc05ad72648e9f6c31cd5f17ad34f1ed3a300eeb38a4a703d3414c113d3e5a9
DIST teamviewer_12.0.85001_i386.deb 46549564 BLAKE2B d3b821376c9385a1090e12708e17b8ad76f29f27c9d76ae140654eed7eca44d115275cd587462e52845260bd6616c88260c767350944730c30eac7c14467ae39 SHA512 4db490568936ec58a37157019071cf61ed5dde8b5951f6e524d1f64aa23f46dd40c8eda1e96a9d47c756c1427d82ccb9c58773b53dfa0ae60bbb94e03b4522a0
+DIST teamviewer_13.0.5693_amd64.tar.xz 9694952 BLAKE2B 650814c3c63897e1024836528c6eaa4cc81064ffa16bece7f8d2fe633457e2795e2cef847175a88dbb389ba61d2597a02292e6bf610da25c92f97152560ea355 SHA512 75886b6d00991968ae0b0d3c55b4c07c6f1b1b24488b2d5ae866e35c26ee6e673e500c87845ba6850ffdc80e4612feff0fc5bbe9e39f2d0a94582e1800471dcc
+DIST teamviewer_13.0.5693_i386.tar.xz 9583892 BLAKE2B 8e477978825431a01b37b61c28b903b36cd81365c7ec5df4ca8d4aec1ce8d24b49af60ed6c99c863acd26405254ae78c4ae4dfef1f8b7a5fb882e281c3c4f125 SHA512 be5e8e00755a38f2c70ceba88d9fb87c2cc8e9e284c86e22f95dddf919a37ee1f24ef1e02f042a339eaf863dbf255c873e3edcb038c04202b4ab0460e50b2503
diff --git a/net-misc/teamviewer/files/teamviewerd13.init b/net-misc/teamviewer/files/teamviewerd13.init
new file mode 100644
index 000000000000..bb6e23884b6b
--- /dev/null
+++ b/net-misc/teamviewer/files/teamviewerd13.init
@@ -0,0 +1,8 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/opt/teamviewer/tv_bin/teamviewerd"
+command_args="-d"
+description="Starts the TeamViewer remote control daemon"
+pidfile="/var/run/teamviewerd.pid"
diff --git a/net-misc/teamviewer/teamviewer-13.0.5693.ebuild b/net-misc/teamviewer/teamviewer-13.0.5693.ebuild
new file mode 100644
index 000000000000..768c644d3290
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-13.0.5693.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MV=${PV/\.*}
+MY_PN=${PN}${MV}
+inherit eutils gnome2-utils systemd
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${MV}x/${PN}_${PV}_amd64.tar.xz )
+ x86? ( https://dl.tvcdn.de/download/linux/version_${MV}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="${MV}"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/dbus
+"
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/teamviewer/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+ default
+
+ # Switch operation mode from 'portable' to 'installed'
+ sed -i 's/TAR_NI/TAR_IN/g' tv_bin/script/tvw_config || die
+}
+
+src_install() {
+ local dst="/opt/teamviewer" # install destination
+
+ # Quirk:
+ # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+ # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+ # when changing the ABI of one of its dependencies. According to the
+ # TeamViewer devs, this binary is an unused remnant of previous Wine-
+ # based builds and will be removed in future releases anyway
+ rm tv_bin/script/libdepend
+
+ insinto ${dst}
+ doins -r tv_bin
+
+ # Set permissions for executables and libraries
+ for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+ fperms 755 ${dst}/${exe}
+ done
+
+ newinitd "${FILESDIR}"/teamviewerd13.init teamviewerd
+ systemd_dounit tv_bin/script/teamviewerd.service
+
+ insinto /usr/share/dbus-1/services
+ doins tv_bin/script/com.teamviewer.TeamViewer.service
+ doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+ insinto /usr/share/polkit-1/actions
+ doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+ for size in 16 24 32 48 256; do
+ newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+ done
+
+ # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+ # have the undesired result of installing subdirectory 'doc' in /usr/
+ # share/doc/teamviewer-<version>)
+ for doc in $(find doc -type f); do
+ dodoc ${doc}
+ done
+
+ keepdir /etc/teamviewer
+ dosym /etc/teamviewer ${dst}/config
+
+ # Create directory and symlink for log files (NOTE: according to Team-
+ # Viewer devs, all paths are hard-coded in the binaries; therefore
+ # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+ # <major-version>')
+ keepdir /var/log/teamviewer${MV}
+ dosym /var/log/teamviewer${MV} ${dst}/logfiles
+
+ dodir /opt/bin
+ dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+ dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+ make_desktop_entry teamviewer "TeamViewer" TeamViewer
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "Before using TeamViewer, you need to start its daemon:"
+ elog "OpenRC:"
+ elog "# /etc/init.d/teamviewerd start"
+ elog "# rc-update add teamviewerd default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start teamviewerd.service"
+ elog "# systemctl enable teamviewerd.service"
+ elog
+ elog "To display additional command line options simply run:"
+ elog "$ ${MY_PN} help"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}