summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-03-14 16:34:44 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-03-14 16:44:03 -0500
commit72a46ec2c5a13914c09afa2571b7f00bfe41a63a (patch)
tree7720faaae706ba0f31a040df313e5e1155404baf
parentapp-emulation/spice-protocol: port live ebuild to meson (diff)
downloadgentoo-72a46ec2c5a13914c09afa2571b7f00bfe41a63a.tar.gz
gentoo-72a46ec2c5a13914c09afa2571b7f00bfe41a63a.tar.bz2
gentoo-72a46ec2c5a13914c09afa2571b7f00bfe41a63a.zip
app-emulation/spice: port live ebuild to meson
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--app-emulation/spice/spice-9999.ebuild56
1 files changed, 22 insertions, 34 deletions
diff --git a/app-emulation/spice/spice-9999.ebuild b/app-emulation/spice/spice-9999.ebuild
index 87b4771fb046..6390d08a37a5 100644
--- a/app-emulation/spice/spice-9999.ebuild
+++ b/app-emulation/spice/spice-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit autotools eutils git-r3 python-any-r1 readme.gentoo-r1 xdg-utils
+inherit eutils git-r3 meson python-any-r1 readme.gentoo-r1 xdg-utils
DESCRIPTION="SPICE server"
HOMEPAGE="https://www.spice-space.org/"
@@ -14,21 +14,21 @@ EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice.git"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="libressl lz4 sasl smartcard static-libs gstreamer"
+IUSE="libressl lz4 sasl smartcard gstreamer"
# the libspice-server only uses the headers of libcacard
RDEPEND="
- dev-lang/orc[static-libs(+)?]
- >=dev-libs/glib-2.22:2[static-libs(+)?]
- media-libs/opus[static-libs(+)?]
- sys-libs/zlib[static-libs(+)?]
- virtual/jpeg:0=[static-libs(+)?]
- >=x11-libs/pixman-0.17.7[static-libs(+)?]
- !libressl? ( dev-libs/openssl:0=[static-libs(+)?] )
- libressl? ( dev-libs/libressl:0=[static-libs(+)?] )
- lz4? ( app-arch/lz4:0=[static-libs(+)?] )
+ dev-lang/orc
+ >=dev-libs/glib-2.22:2
+ media-libs/opus
+ sys-libs/zlib
+ virtual/jpeg:0=
+ >=x11-libs/pixman-0.17.7
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ lz4? ( app-arch/lz4:0= )
smartcard? ( >=app-emulation/libcacard-0.1.2 )
- sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )
+ sasl? ( dev-libs/cyrus-sasl )
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
@@ -52,16 +52,6 @@ pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
}
-src_prepare() {
- default
-
- # Delete repo-only Makefile that causes build to fail.
- # https://gitlab.freedesktop.org/spice/spice/issues/35
- rm GNUmakefile || die
-
- eautoreconf
-}
-
src_configure() {
# Prevent sandbox violations, bug #586560
# https://bugzilla.gnome.org/show_bug.cgi?id=744134
@@ -70,15 +60,14 @@ src_configure() {
xdg_environment_reset
- local myconf="
- $(use_enable static-libs static)
- $(use_enable lz4)
- $(use_with sasl)
- $(use_enable smartcard)
- --enable-gstreamer=$(usex gstreamer "1.0" "no")
- --disable-celt051
- "
- econf ${myconf}
+ local emesonargs=(
+ $(meson_use lz4)
+ $(meson_use sasl)
+ $(meson_feature smartcard)
+ -Dgstreamer=$(usex gstreamer "1.0" "no")
+ -Dcelt051=disabled
+ )
+ meson_src_configure
}
src_compile() {
@@ -87,12 +76,11 @@ src_compile() {
# https://bugzilla.gnome.org/show_bug.cgi?id=744135
addpredict /dev
- default
+ meson_src_compile
}
src_install() {
- default
- use static-libs || find "${D}" -name '*.la' -type f -delete || die
+ meson_src_install
readme.gentoo_create_doc
}