summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-02-08 20:24:37 -0500
committerMike Gilbert <floppym@gentoo.org>2020-02-08 20:25:15 -0500
commit72a9a1fe6d2f43079b8803efd1710e51a50848db (patch)
tree4473267ca059079a494ca854b2bda75e95ad6ca0
parentapp-shells/bash: Removed old (diff)
downloadgentoo-72a9a1fe6d2f43079b8803efd1710e51a50848db.tar.gz
gentoo-72a9a1fe6d2f43079b8803efd1710e51a50848db.tar.bz2
gentoo-72a9a1fe6d2f43079b8803efd1710e51a50848db.zip
dev-python/python-systemd: support python3.8
And other ebuild cleanup. Package-Manager: Portage-2.3.87_p10, Repoman-2.3.20_p57 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-python/python-systemd/python-systemd-234.ebuild26
1 files changed, 8 insertions, 18 deletions
diff --git a/dev-python/python-systemd/python-systemd-234.ebuild b/dev-python/python-systemd/python-systemd-234.ebuild
index 02b6eba8206b..8f0b98cc2c84 100644
--- a/dev-python/python-systemd/python-systemd-234.ebuild
+++ b/dev-python/python-systemd/python-systemd-234.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2015-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS="no"
inherit distutils-r1
@@ -16,26 +17,15 @@ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-COMMON_DEPEND="
- sys-apps/systemd:0=
-"
-DEPEND="${COMMON_DEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="${COMMON_DEPEND}
+BDEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="sys-apps/systemd:0="
+RDEPEND="${DEPEND}
!sys-apps/systemd[python(-)]
"
-PATCHES=(
-)
-
python_compile() {
- if python_is_python3; then
- # https://bugs.gentoo.org/690316
- distutils-r1_python_compile -j1
- else
- distutils-r1_python_compile
- fi
+ # https://bugs.gentoo.org/690316
+ distutils-r1_python_compile -j1
}
python_test() {