summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-02 22:56:35 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-02 23:04:11 -0800
commit72f76b2ec8ffe09b12e7594eeb938379038d6c74 (patch)
tree6734d1c87e5af7829385d35bb364c99419e3d083
parentapp-admin/hddtemp: Revbump to ensure everyone gets the additions (diff)
downloadgentoo-72f76b2ec8ffe09b12e7594eeb938379038d6c74.tar.gz
gentoo-72f76b2ec8ffe09b12e7594eeb938379038d6c74.tar.bz2
gentoo-72f76b2ec8ffe09b12e7594eeb938379038d6c74.zip
sys-libs/libvpd: bump to 2.2.7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-libs/libvpd/Manifest1
-rw-r--r--sys-libs/libvpd/libvpd-2.2.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-libs/libvpd/Manifest b/sys-libs/libvpd/Manifest
index 8b5f0441602b..bb4f318d9245 100644
--- a/sys-libs/libvpd/Manifest
+++ b/sys-libs/libvpd/Manifest
@@ -1 +1,2 @@
DIST libvpd-2.2.6.tar.gz 374262 BLAKE2B b7741948aa62ad6221d28a674f765d085e1446c0bb45d7aa7a5f08599471023b2bb794ad5645c3b70af5806cd48cc87f117f9b4021e0f8c872ca48b748cc1e60 SHA512 17046eeb6ccc5372d465848eff7135cf6e9f876a2d82862e1d01a9f674b691958942e119f846bc3220c1e8f7eb549c5c7867d5d5e896072c733f400d202abc1d
+DIST libvpd-2.2.7.tar.gz 52434 BLAKE2B 6d23649edc8e7cfbd033ad4ace9ad00326b75486db1626d962911d1a14e3f54ee031310f6949b7e266813dfab00f71f23260a8d23311e555312a5251ca165eab SHA512 fe8399e8a7f47219d40c168cfe802ce391aa06a3d80a85bb806aa9f92944bd51b3cfa593f388769a7871f8ac6aef9d7e4bda2ac598cc6f8e193766b0c68bb7d1
diff --git a/sys-libs/libvpd/libvpd-2.2.7.ebuild b/sys-libs/libvpd/libvpd-2.2.7.ebuild
new file mode 100644
index 000000000000..9c9a0165e233
--- /dev/null
+++ b/sys-libs/libvpd/libvpd-2.2.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools udev
+
+DESCRIPTION="Library implementation for listing Vital Product Data"
+HOMEPAGE="https://github.com/power-ras/libvpd"
+SRC_URI="https://github.com/power-ras/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+
+DEPEND="
+ dev-db/sqlite:3
+ sys-libs/zlib:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # sysconfdir is used only to establish where the udev rules file should go
+ # unfortunately it also adds the subdirs on its own so we strip it down to
+ # dirname
+ local myconf=(
+ --disable-static
+ --localstatedir="${EPREFIX}/var"
+ --sysconfdir="$( dirname $(get_udevdir) )"
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib/lsvpd
+ find "${D}" -name '*.la' -delete || die
+}