summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-12-19 09:59:49 -0500
committerMike Gilbert <floppym@gentoo.org>2015-12-19 10:03:08 -0500
commit7394650daff30599077ed9d9544b05f8c90dae21 (patch)
tree5e066fb16851b87d6cdb102f069a4cdd3c86c68f
parentdev-ml/ocaml-cstruct: bump to 1.7.1 (diff)
downloadgentoo-7394650daff30599077ed9d9544b05f8c90dae21.tar.gz
gentoo-7394650daff30599077ed9d9544b05f8c90dae21.tar.bz2
gentoo-7394650daff30599077ed9d9544b05f8c90dae21.zip
dev-python/python-systemd: Bump to 231
Package-Manager: portage-2.2.26_p32
-rw-r--r--dev-python/python-systemd/Manifest1
-rw-r--r--dev-python/python-systemd/files/231-test_daemon-SO_PASSCRED.patch28
-rw-r--r--dev-python/python-systemd/python-systemd-231.ebuild35
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/python-systemd/Manifest b/dev-python/python-systemd/Manifest
index 0850f1f468b1..57c069ea4b0b 100644
--- a/dev-python/python-systemd/Manifest
+++ b/dev-python/python-systemd/Manifest
@@ -1 +1,2 @@
DIST python-systemd-230.tar.gz 39329 SHA256 656a83ff695f5de7d63411a86ea38601ad5a918595eebd0817d7b8e68642c64d SHA512 3c26c59b9005a45c3aeea8a6838ece9b5aa27dd7394ebe75319c1536b52462a847f18a79fdc8cf3bf6df9a70af63c84d5ff66a9587519dd9a006cc3df4966ce8 WHIRLPOOL 0de7ff6919bdf1c6c9cdafd71944801396157281fae1583bb060da4cf800369f97bb0c9f484f81635ed8b2e170db2bbbecf59adac0470a910167333f93c607e6
+DIST python-systemd-231.tar.gz 44430 SHA256 2c9cf53d041374898beead0c6f3b042c7d5b52425e6eb4d4b3c583d7eac12eea SHA512 b1567bd8e99025cc3b5aaeaab6539af8a5307068c403c0f1628bebc518ded80d0843b804244d1f252c858229f7f9578ce9aa988ded25f55999b0d355ce8a3455 WHIRLPOOL 4a1e05687080e8613ae607f837f39672727e60fc7bca1bca445f46413ce16280ab3bfaa30e969414d0da41f06420b7ef59043d2624dc50342cbe2d6df6add449
diff --git a/dev-python/python-systemd/files/231-test_daemon-SO_PASSCRED.patch b/dev-python/python-systemd/files/231-test_daemon-SO_PASSCRED.patch
new file mode 100644
index 000000000000..d62f34ecbeb0
--- /dev/null
+++ b/dev-python/python-systemd/files/231-test_daemon-SO_PASSCRED.patch
@@ -0,0 +1,28 @@
+From a129428dcd92095dc5f3c7ac4b4f096181129063 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sat, 19 Dec 2015 09:42:49 -0500
+Subject: [PATCH] test_daemon: Define a default value for SO_PASSCRED
+
+The socket module seems to be missing this in python2.7.
+---
+ systemd/test/test_daemon.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/systemd/test/test_daemon.py b/systemd/test/test_daemon.py
+index e055048..8c776d5 100644
+--- a/systemd/test/test_daemon.py
++++ b/systemd/test/test_daemon.py
+@@ -228,7 +228,9 @@ def test_notify_with_socket(tmpdir):
+ path = tmpdir.join('socket').strpath
+ sock = socket.socket(socket.AF_UNIX, socket.SOCK_DGRAM)
+ sock.bind(path)
+- sock.setsockopt(socket.SOL_SOCKET, socket.SO_PASSCRED, 1)
++ # SO_PASSCRED is not defined in python2.7
++ SO_PASSCRED = getattr(socket, 'SO_PASSCRED', 16)
++ sock.setsockopt(socket.SOL_SOCKET, SO_PASSCRED, 1)
+ os.environ['NOTIFY_SOCKET'] = path
+
+ assert notify('READY=1') == True
+--
+2.6.4
+
diff --git a/dev-python/python-systemd/python-systemd-231.ebuild b/dev-python/python-systemd/python-systemd-231.ebuild
new file mode 100644
index 000000000000..1b1f6e441d8a
--- /dev/null
+++ b/dev-python/python-systemd/python-systemd-231.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/systemd/python-systemd"
+SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ sys-apps/systemd:0=
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd[python(-)]
+"
+
+PATCHES=(
+ "${FILESDIR}"/231-test_daemon-SO_PASSCRED.patch
+)
+
+python_test() {
+ py.test "${BUILD_DIR}/lib" || die
+}