summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 04:12:45 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:53:59 +0100
commit73d835fcec99baa8c0e684796d36e8992d457cf6 (patch)
treee10b1d709acc3549c0a9ebfd0e2788d5aef53340
parentapp-arch/makeself: EAPI 7, eutils-- (diff)
downloadgentoo-73d835fcec99baa8c0e684796d36e8992d457cf6.tar.gz
gentoo-73d835fcec99baa8c0e684796d36e8992d457cf6.tar.bz2
gentoo-73d835fcec99baa8c0e684796d36e8992d457cf6.zip
app-arch/mt-st: eutils--, respect CPPFLAGS too
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-arch/mt-st/mt-st-1.3.ebuild10
-rw-r--r--app-arch/mt-st/mt-st-1.4.ebuild3
-rw-r--r--app-arch/mt-st/mt-st-9999.ebuild4
3 files changed, 9 insertions, 8 deletions
diff --git a/app-arch/mt-st/mt-st-1.3.ebuild b/app-arch/mt-st/mt-st-1.3.ebuild
index 6124ae9ca95d..5d5cae52801e 100644
--- a/app-arch/mt-st/mt-st-1.3.ebuild
+++ b/app-arch/mt-st/mt-st-1.3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="control magnetic tape drive operation"
+DESCRIPTION="Control magnetic tape drive operation"
HOMEPAGE="https://github.com/iustin/mt-st"
SRC_URI="https://github.com/iustin/mt-st/releases/download/${P}/${P}.tar.gz"
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
}
src_install() {
diff --git a/app-arch/mt-st/mt-st-1.4.ebuild b/app-arch/mt-st/mt-st-1.4.ebuild
index 8677862cdc02..b63ab7081319 100644
--- a/app-arch/mt-st/mt-st-1.4.ebuild
+++ b/app-arch/mt-st/mt-st-1.4.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="control magnetic tape drive operation"
diff --git a/app-arch/mt-st/mt-st-9999.ebuild b/app-arch/mt-st/mt-st-9999.ebuild
index 6201e07af279..4588f304d124 100644
--- a/app-arch/mt-st/mt-st-9999.ebuild
+++ b/app-arch/mt-st/mt-st-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit git-r3 toolchain-funcs
DESCRIPTION="control magnetic tape drive operation"
@@ -10,7 +11,6 @@ EGIT_REPO_URI="https://github.com/iustin/mt-st"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
src_configure() {
tc-export CC