summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 19:04:05 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 19:13:13 +0200
commit7537862d4fee658321df54d024fad58ac0eb04c1 (patch)
treef57118fb4cc41f3505602382b1cc71b25c8a2fbb
parentgames-fps/doom-data: Drop old (diff)
downloadgentoo-7537862d4fee658321df54d024fad58ac0eb04c1.tar.gz
gentoo-7537862d4fee658321df54d024fad58ac0eb04c1.tar.bz2
gentoo-7537862d4fee658321df54d024fad58ac0eb04c1.zip
games-fps/doomsday: Version bump (#617908)
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-fps/doomsday/Manifest1
-rw-r--r--games-fps/doomsday/doomsday-2.0.3.ebuild78
-rw-r--r--games-fps/doomsday/metadata.xml1
3 files changed, 80 insertions, 0 deletions
diff --git a/games-fps/doomsday/Manifest b/games-fps/doomsday/Manifest
index 372f23582e0b..7d8cb7b307b6 100644
--- a/games-fps/doomsday/Manifest
+++ b/games-fps/doomsday/Manifest
@@ -1 +1,2 @@
+DIST doomsday-2.0.3.tar.gz 18060670 BLAKE2B e01545f5d719310a78f01de77249a72f9c3c61a1d295ee0827475439b63653f613660bdc033c1651180cc390469c89120d262c15c6e22cece52600e2889e1437 SHA512 4f8e737df9e004cf3ac3cf16b84ffce0c85e2180af552bac41a224595c7f6932397c39f7d3e9fa522e1ae62828cb87f564a5fa411e742eb07bbee96f14c3ee7c
DIST doomsday-stable-1.15.8.tar.gz 52054238 BLAKE2B ab33c197a89c5b3a9aa00628cd88edb5b5d2c1116ed72c55f34bd21e8128b6ff056bbc81900a9ea133b2230319e3c0f7ef79df98609980a59dc1f3da41e2195d SHA512 6d1b86c6e364cbd043b0714eb351113c8bbaf98daddde1bf615fe663c15a763e26d3e478d1adeb6d8a75ed4c89a5a19f3a891e12ea5937ff2fc54b84118f642c
diff --git a/games-fps/doomsday/doomsday-2.0.3.ebuild b/games-fps/doomsday/doomsday-2.0.3.ebuild
new file mode 100644
index 000000000000..8e474baec7fa
--- /dev/null
+++ b/games-fps/doomsday/doomsday-2.0.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 readme.gentoo-r1 cmake-utils
+
+DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
+HOMEPAGE="http://www.dengine.net"
+SRC_URI="https://downloads.sourceforge.net/project/deng/Doomsday%20Engine/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="fluidsynth openal +doom demo freedoom heretic hexen tools fmod"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ demo? ( doom ) freedoom? ( doom )
+"
+
+RDEPEND="
+ >=dev-util/cmake-3.1
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtgui:5[-gles2]
+ dev-qt/qtcore:5
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/assimp
+ fmod? ( media-libs/fmod )
+ fluidsynth? ( media-sound/fluidsynth )
+ openal? ( media-libs/openal )
+ tools? ( sys-libs/ncurses:0 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+PDEPEND="
+ demo? ( games-fps/doom-data )
+ freedoom? ( games-fps/freedoom )
+"
+
+S="${WORKDIR}/${P}/${PN}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You need to copy Doom, Doom 2, Chex Quest, Heretic, Hexen, HexenDD,
+and Doom64 wads to a folder of your choice. Then configure in game
+engine where that folder is. This is different than old versions,
+which had centralized launchers for each game, and required the
+files to be in a specific place
+"
+
+internal_src_configure() {
+ export QT_SELECT=qt5
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DDENG_ASSIMP_EMBEDDED=off
+ )
+ cmake-utils_src_configure
+}
+
+src_configure() {
+ python_foreach_impl internal_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/games-fps/doomsday/metadata.xml b/games-fps/doomsday/metadata.xml
index daf0c62634d3..8c49e302718e 100644
--- a/games-fps/doomsday/metadata.xml
+++ b/games-fps/doomsday/metadata.xml
@@ -9,6 +9,7 @@
<flag name="demo">Install launcher dor doom1.wad from <pkg>games-fps/doom-data</pkg></flag>
<flag name="doom">Install launcher for jdoom game</flag>
<flag name="fluidsynth">Build the FluidSynth sound driver</flag>
+ <flag name="fmod">Enable support for fmod music and sound effects lib</flag>
<flag name="freedoom">Install launcher for doom1.wad from <pkg>games-fps/freedoom</pkg></flag>
<flag name="heretic">Install launcher for jheretic game</flag>
<flag name="hexen">Install launcher for jhexen game</flag>