summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-28 20:06:44 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-28 20:06:44 -0400
commit75697dab269e22fa1eb3157f378441502bd4b7fc (patch)
tree9c7561d8342f9c73e4994016a47b89c9086e5a1a
parentdev-python/pycountry: version bump (diff)
downloadgentoo-75697dab269e22fa1eb3157f378441502bd4b7fc.tar.gz
gentoo-75697dab269e22fa1eb3157f378441502bd4b7fc.tar.bz2
gentoo-75697dab269e22fa1eb3157f378441502bd4b7fc.zip
dev-python/pyamf: version bump
-rw-r--r--dev-python/pyamf/Manifest1
-rw-r--r--dev-python/pyamf/pyamf-0.7.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyamf/Manifest b/dev-python/pyamf/Manifest
index ab69ca07eff2..7ce6de7fc79f 100644
--- a/dev-python/pyamf/Manifest
+++ b/dev-python/pyamf/Manifest
@@ -1 +1,2 @@
DIST PyAMF-0.7.0.tar.gz 1647988 SHA256 5e9c68a2acc00ee99d1ca1f578c4fc0cbc16e33339a6d5a0d8d313a4c0f42663 SHA512 dcaf808a11c73f9e9b548c9e81100eb28ee1e3c1e2d44b0fb08f58ab3693a49c69b95040e25e612e3864d268436829c4ab7389e1ed9c0704f37a9d350dd9c82d WHIRLPOOL 535fdedea37a866045a34f89b5f255f13d4d3ebc1a1a1fbdba2c233fdd5fedfb1436e4993d69940cbdd5f26898c3d6264afa9bdac21217f38d3d2e955058c369
+DIST PyAMF-0.7.2.tar.gz 1648116 SHA256 3e39d43989f75a4d35f4c2a591d8163637f67eaf856bdae749bd8b64b1c1b672 SHA512 5372e40752a75919122c1a8630dbf6333ca2c9d8c79d004a58f857b2656e2cccd96ba5ff24aca9352a8db2e66419760cf3309b5cafb7ad5e1097473fa4a8bbe8 WHIRLPOOL 5ba25ed6ee2bde8dc2800c6d5093509622214a2ed5a5cf51a023c0a8a72618f7156b550e67816bc51f53d2f84c9993fdc8caf37a4ad23bb1006b08522f38cdec
diff --git a/dev-python/pyamf/pyamf-0.7.2.ebuild b/dev-python/pyamf/pyamf-0.7.2.ebuild
new file mode 100644
index 000000000000..405b0fe77502
--- /dev/null
+++ b/dev-python/pyamf/pyamf-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=PyAMF
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Action Message Format (AMF) support for Python"
+HOMEPAGE="https://github.com/hydralabs/pyamf https://pypi.python.org/pypi/PyAMF"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "PyAMF optionally integrates with several third-party libraries"
+ elog "and web frameworks. See the README or the Optional Extras section at"
+ elog "https://github.com/hydralabs/pyamf/blob/master/doc/install.rst"
+ fi
+}