summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2020-01-18 11:16:43 +0100
committerCédric Krier <cedk@gentoo.org>2020-01-18 11:16:53 +0100
commit75ab388631c07733478905373baffc7005f4f90d (patch)
tree3dbf1203d39b76df62b65b19df1344b445ce6cb3
parentx11-misc/xlockmore: Drop ax_pthread.m4 (diff)
downloadgentoo-75ab388631c07733478905373baffc7005f4f90d.tar.gz
gentoo-75ab388631c07733478905373baffc7005f4f90d.tar.bz2
gentoo-75ab388631c07733478905373baffc7005f4f90d.zip
dev-util/cookiecutter: Version bumps
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Cédric Krier <cedk@gentoo.org>
-rw-r--r--dev-util/cookiecutter/Manifest1
-rw-r--r--dev-util/cookiecutter/cookiecutter-1.7.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/Manifest b/dev-util/cookiecutter/Manifest
index eb29956d2278..1e003fb68049 100644
--- a/dev-util/cookiecutter/Manifest
+++ b/dev-util/cookiecutter/Manifest
@@ -1 +1,2 @@
DIST cookiecutter-1.6.0.tar.gz 255579 BLAKE2B 68d50bc51cc0fa2f7fa84bf77933ad27b4dbdd9c06ed459c5aad8d604256c205bad5434b19b1b93ee95fdf5bf211124558994a9204a79cdfc1e433576a0e7fba SHA512 0a06ae8fe7aceeeb0bcb98b5981d743b2e2e5d5f121c2e0703bb76399b0433816beaddb64c92f28d50f1781737db25907a10ec7b59f6c02c17171cfb56fb12f4
+DIST cookiecutter-1.7.0.tar.gz 249612 BLAKE2B 6ebf09d67640eead22da65d7226c20ebda9a38a36083f5c243e2594db228b21ac665fd7629be1440a78dd69116ba731b7f129489723c6826347acc01cb6eedfb SHA512 2840a3e4c3072f76f79965d29bf9774f79d9f641a1ee96e3b8fdb714f67fd2e1f34020e148767759a083bff67f31f7cab2de311eeaf8a816d12b128b40563c19
diff --git a/dev-util/cookiecutter/cookiecutter-1.7.0.ebuild b/dev-util/cookiecutter/cookiecutter-1.7.0.ebuild
new file mode 100644
index 000000000000..76f1d784ee90
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/audreyr/cookiecutter"
+
+SRC_URI="https://github.com/audreyr/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/future-0.15.2[${PYTHON_USEDEP}]
+ >=dev-python/binaryornot-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/whichcraft-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/poyo-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-time-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.1[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-vcs/git )"
+
+DOCS=( README.md HISTORY.md CONTRIBUTING.md )
+
+python_test() {
+ py.test || die
+}