summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-07-04 13:34:30 -0400
committerMike Gilbert <floppym@gentoo.org>2022-07-04 13:38:14 -0400
commit76303199fc06f8817c0c298ac37f8e0786b77af7 (patch)
tree60b078c62f0fbfa48d476abe2bf1310aa2030a71
parentsys-apps/systemd: drop 250.4-r2, 250.6 (diff)
downloadgentoo-76303199fc06f8817c0c298ac37f8e0786b77af7.tar.gz
gentoo-76303199fc06f8817c0c298ac37f8e0786b77af7.tar.bz2
gentoo-76303199fc06f8817c0c298ac37f8e0786b77af7.zip
sys-apps/systemd: rename 'nat' USE flag to 'iptables'
Since v248, systemd has supported using nftables by default if the running kernel supports it. This makes the iptables dependency an optional fallback. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-apps/systemd/metadata.xml2
-rw-r--r--sys-apps/systemd/systemd-250.7.ebuild8
-rw-r--r--sys-apps/systemd/systemd-251.2.ebuild8
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild8
4 files changed, 13 insertions, 13 deletions
diff --git a/sys-apps/systemd/metadata.xml b/sys-apps/systemd/metadata.xml
index 0d8cc3d2f286..b6426bde80a1 100644
--- a/sys-apps/systemd/metadata.xml
+++ b/sys-apps/systemd/metadata.xml
@@ -23,9 +23,9 @@
<flag name="hostnamed-fallback">Enable setting hostname with networkd/hostnamed without polkit (requires running <pkg>sys-apps/dbus-broker</pkg>)</flag>
<flag name="http">Enable embedded HTTP server in journald</flag>
<flag name="importd">Enable import daemon</flag>
+ <flag name="iptables">Use libiptc from <pkg>net-firewall/iptables</pkg> for NAT support in systemd-networkd; this is used only if the running kernel does not support nftables</flag>
<flag name="kmod">Enable kernel module loading via <pkg>sys-apps/kmod</pkg></flag>
<flag name="lz4">Enable lz4 compression for the journal</flag>
- <flag name="nat">Enable support for network address translation in networkd</flag>
<flag name="openssl">Enable use of <pkg>dev-libs/openssl</pkg> for various features</flag>
<flag name="pkcs11">Enable PKCS#11 support for cryptsetup and homed</flag>
<flag name="pwquality">Enable password quality checking in homed</flag>
diff --git a/sys-apps/systemd/systemd-250.7.ebuild b/sys-apps/systemd/systemd-250.7.ebuild
index 92bbec7305b4..6c099f218fd6 100644
--- a/sys-apps/systemd/systemd-250.7.ebuild
+++ b/sys-apps/systemd/systemd-250.7.ebuild
@@ -35,8 +35,8 @@ LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0/2"
IUSE="
acl apparmor audit build cgroup-hybrid cryptsetup curl +dns-over-tls elfutils
- fido2 +gcrypt gnuefi gnutls homed hostnamed-fallback http idn importd +kmod
- +lz4 lzma nat +openssl pam pcre pkcs11 policykit pwquality qrcode
+ fido2 +gcrypt gnuefi gnutls homed hostnamed-fallback http idn importd iptables +kmod
+ +lz4 lzma +openssl pam pcre pkcs11 policykit pwquality qrcode
+resolvconf +seccomp selinux split-usr +sysv-utils test tpm vanilla xkb +zstd
"
REQUIRED_USE="
@@ -72,7 +72,7 @@ COMMON_DEPEND="
kmod? ( >=sys-apps/kmod-15:0= )
lz4? ( >=app-arch/lz4-0_p131:0=[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1:0=[${MULTILIB_USEDEP}] )
- nat? ( net-firewall/iptables:0= )
+ iptables? ( net-firewall/iptables:0= )
openssl? ( >=dev-libs/openssl-1.1.0:0= )
pam? ( sys-libs/pam:=[${MULTILIB_USEDEP}] )
pkcs11? ( app-crypt/p11-kit:0= )
@@ -328,7 +328,7 @@ multilib_src_configure() {
$(meson_use lz4)
$(meson_use lzma xz)
$(meson_use zstd)
- $(meson_native_use_bool nat libiptc)
+ $(meson_native_use_bool iptables libiptc)
$(meson_native_use_bool openssl)
$(meson_use pam)
$(meson_native_use_bool pkcs11 p11kit)
diff --git a/sys-apps/systemd/systemd-251.2.ebuild b/sys-apps/systemd/systemd-251.2.ebuild
index 04abbae40454..15de03f9a772 100644
--- a/sys-apps/systemd/systemd-251.2.ebuild
+++ b/sys-apps/systemd/systemd-251.2.ebuild
@@ -35,8 +35,8 @@ LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0/2"
IUSE="
acl apparmor audit build cgroup-hybrid cryptsetup curl +dns-over-tls elfutils
- fido2 +gcrypt gnuefi gnutls homed http idn importd +kmod
- +lz4 lzma nat +openssl pam pcre pkcs11 policykit pwquality qrcode
+ fido2 +gcrypt gnuefi gnutls homed http idn importd iptables +kmod
+ +lz4 lzma +openssl pam pcre pkcs11 policykit pwquality qrcode
+resolvconf +seccomp selinux split-usr +sysv-utils test tpm vanilla xkb +zstd
"
REQUIRED_USE="
@@ -71,7 +71,7 @@ COMMON_DEPEND="
kmod? ( >=sys-apps/kmod-15:0= )
lz4? ( >=app-arch/lz4-0_p131:0=[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1:0=[${MULTILIB_USEDEP}] )
- nat? ( net-firewall/iptables:0= )
+ iptables? ( net-firewall/iptables:0= )
openssl? ( >=dev-libs/openssl-1.1.0:0= )
pam? ( sys-libs/pam:=[${MULTILIB_USEDEP}] )
pkcs11? ( app-crypt/p11-kit:0= )
@@ -326,7 +326,7 @@ multilib_src_configure() {
$(meson_use lz4)
$(meson_use lzma xz)
$(meson_use zstd)
- $(meson_native_use_bool nat libiptc)
+ $(meson_native_use_bool iptables libiptc)
$(meson_native_use_bool openssl)
$(meson_use pam)
$(meson_native_use_bool pkcs11 p11kit)
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 0b4f28e4c6b5..b3bc091078ab 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -35,8 +35,8 @@ LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0/2"
IUSE="
acl apparmor audit build cgroup-hybrid cryptsetup curl +dns-over-tls elfutils
- fido2 +gcrypt gnuefi gnutls homed http idn importd +kmod
- +lz4 lzma nat +openssl pam pcre pkcs11 policykit pwquality qrcode
+ fido2 +gcrypt gnuefi gnutls homed http idn importd iptables +kmod
+ +lz4 lzma +openssl pam pcre pkcs11 policykit pwquality qrcode
+resolvconf +seccomp selinux split-usr +sysv-utils test tpm vanilla xkb +zstd
"
REQUIRED_USE="
@@ -71,7 +71,7 @@ COMMON_DEPEND="
kmod? ( >=sys-apps/kmod-15:0= )
lz4? ( >=app-arch/lz4-0_p131:0=[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1:0=[${MULTILIB_USEDEP}] )
- nat? ( net-firewall/iptables:0= )
+ iptables? ( net-firewall/iptables:0= )
openssl? ( >=dev-libs/openssl-1.1.0:0= )
pam? ( sys-libs/pam:=[${MULTILIB_USEDEP}] )
pkcs11? ( app-crypt/p11-kit:0= )
@@ -322,7 +322,7 @@ multilib_src_configure() {
$(meson_use lz4)
$(meson_use lzma xz)
$(meson_use zstd)
- $(meson_native_use_bool nat libiptc)
+ $(meson_native_use_bool iptables libiptc)
$(meson_native_use_bool openssl)
$(meson_use pam)
$(meson_native_use_bool pkcs11 p11kit)