summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 18:20:08 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 19:11:20 +0200
commit76ef192c8f9f1b60b43d8660f018113639bce0ef (patch)
tree0520922b464294283de069226ac6501c9a779427
parentmedia-video/cheese: Drop old (diff)
downloadgentoo-76ef192c8f9f1b60b43d8660f018113639bce0ef.tar.gz
gentoo-76ef192c8f9f1b60b43d8660f018113639bce0ef.tar.bz2
gentoo-76ef192c8f9f1b60b43d8660f018113639bce0ef.zip
media-video/cheese: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--media-video/cheese/Manifest1
-rw-r--r--media-video/cheese/cheese-3.20.2.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index e32ce9d36645..fc9b351e7cc9 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1 +1,2 @@
DIST cheese-3.18.1.tar.xz 1829408 SHA256 fc9d8798b1f0c6b35731f063869a32c6910bab6d0386b9ea36386ebda0d57177 SHA512 37e48f393521b242750d0cbda31537564cd63d2ceb4b3ea6a066c758c8bc9ac632dcbe4ee0ec0b36405c54058ea98ff5744ed087bf928445ffa58fdd2b04d2f7 WHIRLPOOL b996dcfb5f4d3ab72811d7f072dc16d7c0c17109664ce84581659d70786585738b169949f4c9fe2f72df8b48401a30fde96c2557f2a1d888d7bafd38f5de2fef
+DIST cheese-3.20.2.tar.xz 1843696 SHA256 b7c18719b708e039c063ef09278ee813923556e06af4a7e9598c5d3bdeb83775 SHA512 d903ff1d8c7ed728d252dbafbbd73567bb885456b0ae078b68ce605e174d88258d93475019a20caeb653c6f045cd94a4234dd17e50fa958cfb4e9d6ab3096b0e WHIRLPOOL 5fdd4a9f995925e597ca538f2434416f7392e1a30e5174b5f6781809032abd1dac6f7191830c99d159d371029c0ef6ad3b740c3f16046e204abe575c708192d3
diff --git a/media-video/cheese/cheese-3.20.2.ebuild b/media-video/cheese/cheese-3.20.2.ebuild
new file mode 100644
index 000000000000..6b934d862042
--- /dev/null
+++ b/media-video/cheese/cheese-3.20.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_MIN_API_VERSION="0.26"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# using clutter-gst-2.0.0 results in GLSL errors; bug #478702
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ media-libs/clutter-gst:3.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/gst-plugins-base:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ virtual/libgudev:=
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ media-libs/gst-plugins-good:1.0
+
+ media-plugins/gst-plugins-jpeg:1.0
+ media-plugins/gst-plugins-v4l2:1.0
+ media-plugins/gst-plugins-vpx:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto
+ test? ( dev-libs/glib:2[utils] )
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static
+}
+
+src_test() {
+ virtx emake check
+}