summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-28 15:37:03 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-28 16:37:59 +1300
commit77480f8031f9b44881322ff461638240b3abb9fc (patch)
treed5c27165d9deb4c2e9904637be0fc03d0e7ef786
parentkde-apps/kopete: Drop slot 4 (diff)
downloadgentoo-77480f8031f9b44881322ff461638240b3abb9fc.tar.gz
gentoo-77480f8031f9b44881322ff461638240b3abb9fc.tar.bz2
gentoo-77480f8031f9b44881322ff461638240b3abb9fc.zip
dev-perl/PlRPC: EAPI6, tests
- EAPI6ify - Gitify no-perldoc patch ( doesn't apply with EAPI6 ) - Use native perl-module.eclass mechanics for SRC_TEST ( hand-coded version didn't fail with test failures ) - Fix test failures without '.' in @INC - Disable parallel testing Package-Manager: Portage-2.3.18, Repoman-2.3.6
-rw-r--r--dev-perl/PlRPC/PlRPC-0.202.0-r3.ebuild28
-rw-r--r--dev-perl/PlRPC/files/PlRPC-0.2020-no-dot-inc.patch67
-rw-r--r--dev-perl/PlRPC/files/PlRPC-0.2020-no-perldoc.patch27
3 files changed, 122 insertions, 0 deletions
diff --git a/dev-perl/PlRPC/PlRPC-0.202.0-r3.ebuild b/dev-perl/PlRPC/PlRPC-0.202.0-r3.ebuild
new file mode 100644
index 000000000000..fbce70783328
--- /dev/null
+++ b/dev-perl/PlRPC/PlRPC-0.202.0-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MNOONING
+DIST_SECTION=${PN}
+DIST_VERSION=0.2020
+inherit perl-module
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="The Perl RPC Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/perl-Storable-1.0.7
+ >=dev-perl/Net-Daemon-0.34"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2020-no-perldoc.patch"
+ "${FILESDIR}/Security-notice-on-Storable-and-reply-attack.patch"
+ "${FILESDIR}/${PN}-0.2020-no-dot-inc.patch"
+)
+DIST_TEST="do" # Parallel testing fails
diff --git a/dev-perl/PlRPC/files/PlRPC-0.2020-no-dot-inc.patch b/dev-perl/PlRPC/files/PlRPC-0.2020-no-dot-inc.patch
new file mode 100644
index 000000000000..1f68d2395cc5
--- /dev/null
+++ b/dev-perl/PlRPC/files/PlRPC-0.2020-no-dot-inc.patch
@@ -0,0 +1,67 @@
+From 0c3b094e14b60794eb6c4736a51f505865f14403 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 28 Dec 2017 15:08:34 +1300
+Subject: Fix test failures due to '.' in @INC removal on 5.26
+
+---
+ t/client.t | 2 +-
+ t/compress.t | 2 +-
+ t/crypt.t | 2 +-
+ t/methods.t | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/t/client.t b/t/client.t
+index a283f2d..f0b3b54 100644
+--- a/t/client.t
++++ b/t/client.t
+@@ -4,7 +4,7 @@
+ require 5.004;
+ use strict;
+
+-require "t/lib.pl";
++require "./t/lib.pl";
+
+
+ my $numTests = 10;
+diff --git a/t/compress.t b/t/compress.t
+index e13f6b3..a551421 100644
+--- a/t/compress.t
++++ b/t/compress.t
+@@ -10,7 +10,7 @@ if ($@) {
+ exit 0;
+ }
+
+-require "t/lib.pl";
++require "./t/lib.pl";
+
+
+ my $numTests = 18;
+diff --git a/t/crypt.t b/t/crypt.t
+index 2695633..6867349 100644
+--- a/t/crypt.t
++++ b/t/crypt.t
+@@ -10,7 +10,7 @@ if ($@ || $Crypt::DES::VERSION < 2.03) {
+ exit 0;
+ }
+
+-require "t/lib.pl";
++require "./t/lib.pl";
+
+
+ my $numTests = 18;
+diff --git a/t/methods.t b/t/methods.t
+index c9d81ca..1c9b2cd 100644
+--- a/t/methods.t
++++ b/t/methods.t
+@@ -4,7 +4,7 @@
+ require 5.004;
+ use strict;
+
+-require "t/lib.pl";
++require "./t/lib.pl";
+
+
+ my $numTests = 11;
+--
+2.15.1
+
diff --git a/dev-perl/PlRPC/files/PlRPC-0.2020-no-perldoc.patch b/dev-perl/PlRPC/files/PlRPC-0.2020-no-perldoc.patch
new file mode 100644
index 000000000000..d4d916eabe36
--- /dev/null
+++ b/dev-perl/PlRPC/files/PlRPC-0.2020-no-perldoc.patch
@@ -0,0 +1,27 @@
+From d5df770e01a68a8f90c406a7018c820514fd7371 Mon Sep 17 00:00:00 2001
+From: Michael Cummings <mcummings@gentoo.org>
+Date: Tue, 26 Jun 2007 04:02:12 +1200
+Subject: Fix perldoc generation permissions bug
+
+Bizarre bug that showed up randomly here, but Cardoe had it full time.
+
+Bug: https://bugs.gentoo.org/183157
+---
+ Makefile.PL | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 22e04c5..c332ffe 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -86,7 +86,6 @@ sub postamble {
+ pm_to_blib: README
+
+ README: lib/RPC/PlServer.pm
+-\tperldoc -t lib/RPC/PlServer.pm >README
+
+ END_OF_POSTAMBLE
+ }
+--
+2.15.1
+