summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-14 00:14:08 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-14 00:15:05 +0100
commit77a83e39aab60e0e6dd153437ed58d0c9177faee (patch)
treedc0a3cd1446d92f1092ebaf74e39f15ce202491b
parentgames-emulation/dolphin: [QA] Sync live ebuild (diff)
downloadgentoo-77a83e39aab60e0e6dd153437ed58d0c9177faee.tar.gz
gentoo-77a83e39aab60e0e6dd153437ed58d0c9177faee.tar.bz2
gentoo-77a83e39aab60e0e6dd153437ed58d0c9177faee.zip
games-emulation/dolphin: [QA] Add call to 'gnome2_icon_cache_update'
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--games-emulation/dolphin/dolphin-5.0.ebuild8
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0.ebuild b/games-emulation/dolphin/dolphin-5.0.ebuild
index 190053251053..56737af95d72 100644
--- a/games-emulation/dolphin/dolphin-5.0.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0.ebuild
@@ -7,7 +7,7 @@ PLOCALES="ar ca cs da_DK de el en es fa fr hr hu it ja ko ms_MY nb nl pl pt pt_B
PLOCALE_BACKUP="en"
WX_GTK_VER="3.0"
-inherit cmake-utils desktop l10n pax-utils toolchain-funcs versionator wxwidgets
+inherit cmake-utils desktop gnome2-utils l10n pax-utils toolchain-funcs versionator wxwidgets
SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.zip -> ${P}.zip"
KEYWORDS="amd64"
@@ -170,4 +170,10 @@ pkg_postinst() {
ewarn "If you want microphone capabilities in dolphin-emu, rebuild with"
ewarn "USE=\"portaudio\""
fi
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
}
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index f6dddcb6d01f..1df45aa19853 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -7,7 +7,7 @@ PLOCALES="ar ca cs da_DK de el en es fa fr hr hu it ja ko ms_MY nb nl pl pt pt_B
PLOCALE_BACKUP="en"
WX_GTK_VER="3.0"
-inherit cmake-utils desktop l10n pax-utils toolchain-funcs versionator wxwidgets
+inherit cmake-utils desktop gnome2-utils l10n pax-utils toolchain-funcs versionator wxwidgets
if [[ ${PV} == *9999 ]]
then
@@ -174,4 +174,10 @@ pkg_postinst() {
ewarn "If you want microphone capabilities in dolphin-emu, rebuild with"
ewarn "USE=\"portaudio\""
fi
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
}