summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-08-18 21:19:06 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-08-18 21:20:01 +0300
commit7880d1440178922710773941325cfd2b989edf77 (patch)
treed25cd8f697265f6a3c590ddbc2537147207a6f27
parentdev-util/kdevelop: Fix missing header with Frameworks 5.61 (diff)
downloadgentoo-7880d1440178922710773941325cfd2b989edf77.tar.gz
gentoo-7880d1440178922710773941325cfd2b989edf77.tar.bz2
gentoo-7880d1440178922710773941325cfd2b989edf77.zip
dev-tex/pgf: ship revision macro (v3.1.4)
Closes: https://bugs.gentoo.org/692452 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--dev-tex/pgf/Manifest1
-rw-r--r--dev-tex/pgf/pgf-3.1.4-r1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-tex/pgf/Manifest b/dev-tex/pgf/Manifest
index 6a6acfdbbe55..a94d534edf09 100644
--- a/dev-tex/pgf/Manifest
+++ b/dev-tex/pgf/Manifest
@@ -1,4 +1,5 @@
DIST pgf-3.1.4-pgfmanual.pdf 10376398 BLAKE2B 4e45a0d69000d1f89a995f3e5e9295b82a79af5cfd5863aba4f1fd9c3b40d05f2f07b6fc2b34a933136448728aea3dfacc4943fd013896cd4cfe52c9dc8aa3c3 SHA512 a2b934d6e9836fce0a731d238b713ebdc3764e8aa76ea4c7fd54c88f59f31fe17f8c306b6a381adc73becb410e0c6350427112e5d46ae762665fc73fcdca54a0
+DIST pgf-3.1.4-revisioned.tex.xz 244 BLAKE2B 088da7d921dcce118af216fefbedcdde5d3359cdb044d67ec51cd8a595c21aa4d314b33bc49bcd04387e5af1230f7244b136e2bca8fd83a01ee2d264dc89fad5 SHA512 690e3233052c81384b69bae5504c5b5ea1053aaba6444674d3aad7a550f66f4e326c413decf482d7435e7273e9a3a1fddc64ff1946bca0c92e93b8fd66f3f09d
DIST pgf-3.1.4.tar.gz 2426346 BLAKE2B 44d1c709774586b4de81def3d4e7133d147e9e3c1b69078789c8f62378b97a6fc6cfbd580a5f1d292190282dbec5ca4f080d4567b2e1fa526909f08e07169547 SHA512 472ffca8f465bfb5f98cbe0880887afc5b9043bfc878aa8f64a79970502546cc3e0901010b8662aa582af9bc4a90b622ade828c075396542a1e2ee7af694181c
DIST pgf-3.1.4b-pgfmanual.pdf 10371181 BLAKE2B c619e56fd184fea8761175efed7130b37b10f719e04e87b40448a0a72641f2b7c6be0270ae0c2386d91caf06d9cd46f8eb3eb9293d8ff46d8f4a8400662cc1d8 SHA512 f18e836774b8ad8d7a2adb1c876e529240907b9a9c695ab6366d4bc321766106ced3085dc0d17394d6c19654a2232e10d782e93152c075f7915ffb2f0e09b680
DIST pgf-3.1.4b-revisioned.xz 244 BLAKE2B b394702704aa5b16549df795bc4cf04e5a81839a7694a1773dee89f4db66a286a276e48bf080f82e4fe3e55e3a6bf3983394ed84a83a372becc5b8f0738162a7 SHA512 4f5ca04317e58a191eaf7225fdd9a2ff70ad80d601951be98870f77da598ba559b464e2bd0ca4f03cf54c0ccd536925deb8bd6061b9464b36a883727ae85dc40
diff --git a/dev-tex/pgf/pgf-3.1.4-r1.ebuild b/dev-tex/pgf/pgf-3.1.4-r1.ebuild
new file mode 100644
index 000000000000..1523846f629b
--- /dev/null
+++ b/dev-tex/pgf/pgf-3.1.4-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit latex-package
+
+DESCRIPTION="The TeX Portable Graphic Format"
+HOMEPAGE="https://github.com/pgf-tikz/pgf"
+SRC_URI=" https://github.com/pgf-tikz/pgf/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zlogene/distfiles/${CATEGORY}/${PN}/${P}-revisioned.tex.xz
+ doc? ( https://github.com/pgf-tikz/pgf/releases/download/${PV}/pgfmanual.pdf -> ${P}-pgfmanual.pdf )"
+
+LICENSE="GPL-2 LPPL-1.3c FDL-1.2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc source"
+
+RDEPEND="dev-texlive/texlive-latexrecommended
+ dev-tex/xcolor"
+
+src_install() {
+ insinto "${TEXMF}"
+ doins -r tex
+ insinto "${TEXMF}"/tex/generic/${PN}
+ newins "${WORKDIR}"/${P}-revisioned.tex pgf.revision.tex
+
+ if use source ; then
+ doins -r source
+ fi
+
+ cd "${S}/doc/generic/pgf" || die
+ dodoc AUTHORS ChangeLog README
+ if use doc; then
+ insinto /usr/share/doc/${PF}/texdoc
+ # pgfmanual is now split from the main tar archive
+ newdoc "${DISTDIR}/${P}-pgfmanual.pdf" pgfmanual.pdf
+ doins -r images macros text-en version-*
+
+ dosym "/usr/share/doc/${PF}/texdoc" "${TEXMF}/doc/latex/${PN}"
+ docompress -x "/usr/share/doc/${PF}/texdoc/"
+ fi
+}