summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZetok Zalbavar <zetok@openmailbox.org>2016-06-16 20:51:24 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-06-22 06:13:23 +0000
commit78b5a0fae97f6b2230b70cca8d390e25af4e84c8 (patch)
tree2457f5d79311afa1e223197e182e0bb40f632ac8
parentapp-admin/setools: update Homepage (diff)
downloadgentoo-78b5a0fae97f6b2230b70cca8d390e25af4e84c8.tar.gz
gentoo-78b5a0fae97f6b2230b70cca8d390e25af4e84c8.tar.bz2
gentoo-78b5a0fae97f6b2230b70cca8d390e25af4e84c8.zip
net-im/qtox: update to EAPI 6
Also remove no longer needed part from live ebuild, since upstream removed support for filter_audio completely. Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1689 See-Also: https://github.com/tux3/qTox/commit/792103f8b0c76ecec576f7e57efb3edb71 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--net-im/qtox/qtox-1.3.0.ebuild6
-rw-r--r--net-im/qtox/qtox-1.4.0.ebuild6
-rw-r--r--net-im/qtox/qtox-9999.ebuild9
3 files changed, 3 insertions, 18 deletions
diff --git a/net-im/qtox/qtox-1.3.0.ebuild b/net-im/qtox/qtox-1.3.0.ebuild
index 3dffe4b24b58..5c25a9ff2cba 100644
--- a/net-im/qtox/qtox-1.3.0.ebuild
+++ b/net-im/qtox/qtox-1.3.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils qmake-utils
@@ -56,10 +56,6 @@ pkg_pretend() {
fi
}
-src_prepare() {
- epatch_user
-}
-
src_configure() {
use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
diff --git a/net-im/qtox/qtox-1.4.0.ebuild b/net-im/qtox/qtox-1.4.0.ebuild
index 054a45136860..ec6d329a938e 100644
--- a/net-im/qtox/qtox-1.4.0.ebuild
+++ b/net-im/qtox/qtox-1.4.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils qmake-utils
@@ -57,10 +57,6 @@ pkg_pretend() {
fi
}
-src_prepare() {
- epatch_user
-}
-
src_configure() {
use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index 19761c5e85dc..0c69c91103c4 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils qmake-utils git-r3
@@ -56,18 +56,11 @@ pkg_pretend() {
fi
}
-src_prepare() {
- epatch_user
-}
-
src_configure() {
use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
- # filter_audio is disabled since it's not available in Gentoo, and
- # support for it in qTox at the present is ~broken anyway
eqmake5 \
PREFIX="${D}/usr" \
- DISABLE_FILTER_AUDIO=YES \
${NO_GTK_SUPPORT} \
${NO_X_SUPPORT}
}