summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-03-01 06:42:02 +0100
committerHans de Graaff <graaff@gentoo.org>2016-03-01 06:48:29 +0100
commit794e161f0126ce76bafd49a80b757b187d987ef8 (patch)
treedc38f16d6743c3535321da694f6787113dcac3d8
parentmedia-fonts/cantarell: clean up old (diff)
downloadgentoo-794e161f0126ce76bafd49a80b757b187d987ef8.tar.gz
gentoo-794e161f0126ce76bafd49a80b757b187d987ef8.tar.bz2
gentoo-794e161f0126ce76bafd49a80b757b187d987ef8.zip
dev-ruby/activesupport: add rails 4.2.5.2, bug 576068
Package-Manager: portage-2.2.26
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-4.2.5.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 1b70cb2c0243..0054c633732e 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -2,3 +2,4 @@ DIST rails-3.2.22.1.tgz 3570617 SHA256 0678ec5677e6f70a20aa398b323a3d926531e1da2
DIST rails-4.0.13.tgz 3761572 SHA256 a693a8c5f767d153e765634cecb6356855ca51b6554b3af1a38888023a204a51 SHA512 3f2cca90187f800d1ec57fc6cbc58c1f3213113a94d1dee7d9cfd3dc0264b7f3a9c6cfc6dd95ef2fb3aa7d8ca5d6da50cedecc288ff8ff7e5305dc0309b4365d WHIRLPOOL a5b3f7f828a88d04b5687b3217b40903192ccea5eca36ca58cbb2baeec7471241fe5529f13688bd1f6396a384cf282c94bfaf54ee1cfafdf5ef400707dee7d01
DIST rails-4.1.14.1.tgz 3728574 SHA256 1b094a1d1f242c19d2fad0b4f0708d117fce281162d7550535a79c2919246179 SHA512 1ffb3d7f1f5b6db34bbae2015c220945fd780e42bc69242fdcadc6bd59b74c32f16cf54e153b9c3c2aa065d20b1231c19c7ebfe8f8d5f52a1048b8e0f1b7782a WHIRLPOOL 31eb9281d9e0b0e0c07807b14d7b1e52b1a08adc612da9c9c272a5eacb6b095d74b80400eb99818d37371963775942b9d85f38c18446d75de996595528fdf84d
DIST rails-4.2.5.1.tgz 4175926 SHA256 713da4f88244101457b4de5d08007f4b373cb43c3982d72de70bb5c5145afb46 SHA512 3c74d825f35a71dd80a0e1d3959cc6d9e52da0f2eb43bfb869da22a8117ba4f66df1de183851b7cd9e3c2cc8a0b5a8ae4e6902d3b43afd52ccdd20470b49801d WHIRLPOOL dfb4f925468cfbadd73fd54eb146e377df8e4d67aa094076dd928c616d6cfddb9084cee2adb220490df0c34627a99b150118bc7827b2ca5f6d0751611993b53f
+DIST rails-4.2.5.2.tgz 4174380 SHA256 c5dfe36d5ac69f2a852665c2025d289a4d57dc204209b4b3013dcbd0d33f544f SHA512 f2dc1b86c296c9b3862d050a6471f4c529bb246cee6a18106e3e48f588d6a5d665529c95ab94c7d8a9197bf247869805ef908d1255e67641e2cc906e15dcd2e3 WHIRLPOOL 4d933582683d2838fee5d042c1e783afb790a0197b3470969ead3eb79f263cc4862b51bfb30e6a14552473813a8dca237c7241c78f4cc8279c267ba692cbf5d6
diff --git a/dev-ruby/activesupport/activesupport-4.2.5.2.ebuild b/dev-ruby/activesupport/activesupport-4.2.5.2.ebuild
new file mode 100644
index 000000000000..5615eadbba5c
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.2.5.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/i18n-0.7:0.7
+ >=dev-ruby/json-1.7.7:0
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/thread_safe-0.3.4:0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid test that seems to be broken by lack of DST.
+ sed -i -e '369 s:^:#:' test/core_ext/string_ext_test.rb || die
+
+ # Avoid test that fails with Minitest 5.4 since that already defines
+ # a string E in its TestCase.
+ rm test/core_ext/marshal_test.rb || die
+ sed -i -e '/test_const_missing_in_anonymous_modules/askip "gentoo minitest"' test/dependencies_test.rb || die
+}