summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-04-19 11:24:25 -0400
committerAaron Bauman <bman@gentoo.org>2018-04-19 11:24:41 -0400
commit79fe43f8318e385f889bc12bb18f38c69ef5f201 (patch)
tree1798868da34d1a24dd6dbe0369cc747a71cc15ef
parentapp-arch/libarchive: compatibility patch update for LibreSSL (diff)
downloadgentoo-79fe43f8318e385f889bc12bb18f38c69ef5f201.tar.gz
gentoo-79fe43f8318e385f889bc12bb18f38c69ef5f201.tar.bz2
gentoo-79fe43f8318e385f889bc12bb18f38c69ef5f201.zip
app-arch/libarchive: compatibility patch for LibreSSL
This patch is slightly modified from app-arch/libarchive-3.3.1 due to minor upstream modifications. Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--app-arch/libarchive/files/libarchive-3.3.2-libressl.patch25
-rw-r--r--app-arch/libarchive/libarchive-3.3.2.ebuild4
2 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/libarchive/files/libarchive-3.3.2-libressl.patch b/app-arch/libarchive/files/libarchive-3.3.2-libressl.patch
new file mode 100644
index 000000000000..e053a539fae8
--- /dev/null
+++ b/app-arch/libarchive/files/libarchive-3.3.2-libressl.patch
@@ -0,0 +1,25 @@
+--- a/libarchive/archive_openssl_evp_private.h 2017-01-29 05:06:27.000000000 +0000
++++ b/libarchive/archive_openssl_evp_private.h 2018-04-19 04:00:14.061922747 +0000
+@@ -28,7 +28,8 @@
+ #include <openssl/evp.h>
+ #include <openssl/opensslv.h>
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || \
++(defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
+ #include <stdlib.h> /* malloc, free */
+ #include <string.h> /* memset */
+ static inline EVP_MD_CTX *EVP_MD_CTX_new(void)
+
+--- a/libarchive/archive_openssl_hmac_private.h 2017-01-29 05:06:27.000000000 +0000
++++ b/libarchive/archive_openssl_hmac_private.h 2018-04-19 04:02:18.309167446 +0000
+@@ -28,7 +28,8 @@
+ #include <openssl/hmac.h>
+ #include <openssl/opensslv.h>
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || \
++(defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
+ #include <stdlib.h> /* malloc, free */
+ #include <string.h> /* memset */
+ static inline HMAC_CTX *HMAC_CTX_new(void)
diff --git a/app-arch/libarchive/libarchive-3.3.2.ebuild b/app-arch/libarchive/libarchive-3.3.2.ebuild
index f68b736c9464..d82a2179cc3b 100644
--- a/app-arch/libarchive/libarchive-3.3.2.ebuild
+++ b/app-arch/libarchive/libarchive-3.3.2.ebuild
@@ -35,6 +35,10 @@ DEPEND="${RDEPEND}
e2fsprogs? ( sys-fs/e2fsprogs )
)"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.2-libressl.patch
+)
+
# Various test problems, starting with the fact that sandbox
# explodes on long paths. https://bugs.gentoo.org/598806
RESTRICT="test"