summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-03 17:16:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-03 17:16:47 +0200
commit7a42deb3685170c95a34a17ef9a26951d10ca195 (patch)
tree911ca1669df282e2ab6a9b896bd23072c50375bf
parentkde-plasma/plasma-pa: Drop 5.15.4 (r0) (diff)
downloadgentoo-7a42deb3685170c95a34a17ef9a26951d10ca195.tar.gz
gentoo-7a42deb3685170c95a34a17ef9a26951d10ca195.tar.bz2
gentoo-7a42deb3685170c95a34a17ef9a26951d10ca195.zip
dev-util/kdbg: EAPI-7 bump
Use upstream patch to not install broken PNGs, drop pngfix hack. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-util/kdbg/files/kdbg-3.0.0-no-png-install.patch54
-rw-r--r--dev-util/kdbg/kdbg-3.0.0-r1.ebuild43
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-util/kdbg/files/kdbg-3.0.0-no-png-install.patch b/dev-util/kdbg/files/kdbg-3.0.0-no-png-install.patch
new file mode 100644
index 000000000000..237feaa981bd
--- /dev/null
+++ b/dev-util/kdbg/files/kdbg-3.0.0-no-png-install.patch
@@ -0,0 +1,54 @@
+From 826d503da8bfe7c567fc44dee178a4fca2b52f0a Mon Sep 17 00:00:00 2001
+From: Johannes Sixt <j6t@kdbg.org>
+Date: Fri, 15 Feb 2019 20:26:03 +0100
+Subject: [PATCH] Do not install the pulse frames.
+
+Andreas Sturmlechner noticed that the frame PNGs are slightly broken:
+
+ .../pulse000000.png: broken IDAT window length
+
+Since the PNGs are only needed to build pulse.mng, do not install them.
+---
+ kdbg/pics/CMakeLists.txt | 29 -----------------------------
+ 1 file changed, 29 deletions(-)
+
+diff --git a/kdbg/pics/CMakeLists.txt b/kdbg/pics/CMakeLists.txt
+index 41625b3..9615b1b 100644
+--- a/kdbg/pics/CMakeLists.txt
++++ b/kdbg/pics/CMakeLists.txt
+@@ -31,35 +31,6 @@ set(PICTOGRAMS
+ install(FILES ${PICTOGRAMS} DESTINATION "${DATA_INSTALL_DIR}/kdbg/pics")
+
+ ecm_install_icons(ICONS
+- 22-actions-pulse000000.png
+- 22-actions-pulse000001.png
+- 22-actions-pulse000002.png
+- 22-actions-pulse000003.png
+- 22-actions-pulse000004.png
+- 22-actions-pulse000005.png
+- 22-actions-pulse000006.png
+- 22-actions-pulse000007.png
+- 22-actions-pulse000008.png
+- 22-actions-pulse000009.png
+- 22-actions-pulse000010.png
+- 22-actions-pulse000011.png
+- 22-actions-pulse000012.png
+- 22-actions-pulse000013.png
+- 22-actions-pulse000014.png
+- 22-actions-pulse000015.png
+- 22-actions-pulse000016.png
+- 22-actions-pulse000017.png
+- 22-actions-pulse000018.png
+- 22-actions-pulse000019.png
+- 22-actions-pulse000020.png
+- 22-actions-pulse000021.png
+- 22-actions-pulse000022.png
+- 22-actions-pulse000023.png
+- 22-actions-pulse000024.png
+- 22-actions-pulse000025.png
+- 22-actions-pulse000026.png
+- 22-actions-pulse000027.png
+- 22-actions-pulse000028.png
+ 22-actions-pulse.mng
+ DESTINATION "${DATA_INSTALL_DIR}/kdbg/icons"
+ THEME hicolor \ No newline at end of file
diff --git a/dev-util/kdbg/kdbg-3.0.0-r1.ebuild b/dev-util/kdbg/kdbg-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..e8543c0a37c6
--- /dev/null
+++ b/dev-util/kdbg/kdbg-3.0.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="Graphical debugger interface"
+HOMEPAGE="http://www.kdbg.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !dev-util/kdbg:4
+ sys-devel/gdb
+"
+
+PATCHES=( "${FILESDIR}/${P}-no-png-install.patch" )
+
+src_prepare() {
+ # allow documentation to be handled by eclass
+ mv kdbg/doc . || die
+ sed -i -e '/add_subdirectory(doc)/d' kdbg/CMakeLists.txt || die
+ echo "add_subdirectory ( doc ) " >> CMakeLists.txt || die
+
+ kde5_src_prepare
+}