summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-03 23:23:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-15 01:21:24 +0200
commit7a4617fa29b6a10dfef8dbf8679ca7698543c79c (patch)
tree18c5334f672fa5de364fa6e685c78b9ee28930d2
parentdev-libs/libprelude: Drop superfluous calls to python_is_python3 (diff)
downloadgentoo-7a4617fa29b6a10dfef8dbf8679ca7698543c79c.tar.gz
gentoo-7a4617fa29b6a10dfef8dbf8679ca7698543c79c.tar.bz2
gentoo-7a4617fa29b6a10dfef8dbf8679ca7698543c79c.zip
dev-libs/libpreludedb: Drop superfluous calls to python_is_python3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libpreludedb/libpreludedb-4.0.0-r1.ebuild9
-rw-r--r--dev-libs/libpreludedb/libpreludedb-4.1.0-r1.ebuild9
-rw-r--r--dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild9
3 files changed, 9 insertions, 18 deletions
diff --git a/dev-libs/libpreludedb/libpreludedb-4.0.0-r1.ebuild b/dev-libs/libpreludedb/libpreludedb-4.0.0-r1.ebuild
index 97583d45ddbd..bf8921fc1f25 100644
--- a/dev-libs/libpreludedb/libpreludedb-4.0.0-r1.ebuild
+++ b/dev-libs/libpreludedb/libpreludedb-4.0.0-r1.ebuild
@@ -52,6 +52,7 @@ src_configure() {
local myconf=(
--enable-easy-bindings
--with-swig
+ --without-python2
$(use_with mysql)
$(use_with postgres postgresql)
$(use_with sqlite sqlite3)
@@ -59,13 +60,9 @@ src_configure() {
if use python; then
python_setup
- if python_is_python3; then
- myconf+=(--without-python2 --with-python3="${EPYTHON}")
- else
- myconf+=(--without-python3 --with-python2="${EPYTHON}")
- fi
+ myconf+=( --with-python3="${EPYTHON}" )
else
- myconf+=(--without-python2 --without-python3)
+ myconf+=( --without-python3 )
fi
econf "${myconf[@]}"
diff --git a/dev-libs/libpreludedb/libpreludedb-4.1.0-r1.ebuild b/dev-libs/libpreludedb/libpreludedb-4.1.0-r1.ebuild
index c406020aba17..2cc2fe00385c 100644
--- a/dev-libs/libpreludedb/libpreludedb-4.1.0-r1.ebuild
+++ b/dev-libs/libpreludedb/libpreludedb-4.1.0-r1.ebuild
@@ -52,6 +52,7 @@ src_configure() {
local myconf=(
--enable-easy-bindings
--with-swig
+ --without-python2
$(use_with mysql)
$(use_with postgres postgresql)
$(use_with sqlite sqlite3)
@@ -59,13 +60,9 @@ src_configure() {
if use python; then
python_setup
- if python_is_python3; then
- myconf+=(--without-python2 --with-python3="${EPYTHON}")
- else
- myconf+=(--without-python3 --with-python2="${EPYTHON}")
- fi
+ myconf+=( --with-python3="${EPYTHON}" )
else
- myconf+=(--without-python2 --without-python3)
+ myconf+=( --without-python3 )
fi
econf "${myconf[@]}"
diff --git a/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild b/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild
index dd429b891a4f..9e2c81a16649 100644
--- a/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild
+++ b/dev-libs/libpreludedb/libpreludedb-5.1.0.ebuild
@@ -58,6 +58,7 @@ src_configure() {
local myconf=(
--enable-easy-bindings
--with-swig
+ --without-python2
$(use_with mysql)
$(use_with postgres postgresql)
$(use_with sqlite sqlite3)
@@ -65,13 +66,9 @@ src_configure() {
if use python; then
python_setup
- if python_is_python3; then
- myconf+=(--without-python2 --with-python3="${EPYTHON}")
- else
- myconf+=(--without-python3 --with-python2="${EPYTHON}")
- fi
+ myconf+=( --with-python3="${EPYTHON}" )
else
- myconf+=(--without-python2 --without-python3)
+ myconf+=( --without-python3 )
fi
econf "${myconf[@]}"