summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-23 02:36:37 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-23 02:36:37 -0400
commit7a7a400343bbb830dc87f33c5eb8066622c7098f (patch)
tree11f606a1dbed8f6d9bcf46878f1447eb28e6a1f2
parentsys-apps/{acl,attr}: run elibtoolize #580792 (diff)
downloadgentoo-7a7a400343bbb830dc87f33c5eb8066622c7098f.tar.gz
gentoo-7a7a400343bbb830dc87f33c5eb8066622c7098f.tar.bz2
gentoo-7a7a400343bbb830dc87f33c5eb8066622c7098f.zip
sys-fs/hfsplusutils: update to EAPI=5
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
index aa6fe7ce9e43..e11b12018484 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-inherit autotools eutils
+EAPI="5"
+
+inherit autotools eutils flag-o-matic
MY_P="hfsplus_${PV}"
DESCRIPTION="HFS+ Filesystem Access Utilities (a PPC filesystem)"
@@ -19,18 +20,16 @@ RDEPEND=""
S=${WORKDIR}/hfsplus-${PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-glob.patch"
epatch "${FILESDIR}/${P}-errno.patch"
epatch "${FILESDIR}/${P}-gcc4.patch"
epatch "${FILESDIR}/${P}-string.patch"
- #let's avoid the Makefile.cvs since isn't working for us
+ # let's avoid the Makefile.cvs since isn't working for us
eautoreconf
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ default
newman doc/man/hfsp.man hfsp.1
}