summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-09-05 16:01:16 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-09-05 16:01:40 -0500
commit7b22cbbc4ba554e90f31ac0ed122182503321f3d (patch)
treef33a7879126216bdfd3ddb244e7a15671fe8820f
parentnet-analyzer/icinga2: bup (diff)
downloadgentoo-7b22cbbc4ba554e90f31ac0ed122182503321f3d.tar.gz
gentoo-7b22cbbc4ba554e90f31ac0ed122182503321f3d.tar.bz2
gentoo-7b22cbbc4ba554e90f31ac0ed122182503321f3d.zip
dev-python/stormpath: add version 2.1.1
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/stormpath/Manifest1
-rw-r--r--dev-python/stormpath/stormpath-2.1.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/stormpath/Manifest b/dev-python/stormpath/Manifest
index 3c85105c1905..25c04ea78742 100644
--- a/dev-python/stormpath/Manifest
+++ b/dev-python/stormpath/Manifest
@@ -1,2 +1,3 @@
DIST stormpath-2.0.8.tar.gz 4326469 SHA256 9f6ad7e7b210024915e2139b2ed395a7c0fff6ca49ad3cdf58dc8f214d080c70 SHA512 661714fac02528111bb01e30f8c16b1d8701fe894b21d803958331819ce145a9ec03864111b861286224b33aaf56ca68ddcef2b67cd0003c498cd007ce375a03 WHIRLPOOL 12e6f7ec559a654ab59d34106d85d98ada4c7e3dee6fcec6cad0a2500608e962289d73a50e6ce6d81122c43f0f53b30d861203c8a976ac7bdbdab1cd8f5db6be
DIST stormpath-2.0.9.tar.gz 4325976 SHA256 ba93f1f9f6b98db2eb2671d2b3285fdd15f8b2e6d3bce899f240576018f216ae SHA512 b50fa11e8fecf4909a8a1014963c80e7e2dde4db37e1f4681c2a116933d59f5b5ea32901cfde97b24398d8074db8b04121b2a7715d86b6b2eb78eb288465114c WHIRLPOOL 6290d5844d35158cc46f1810b6f83e41c443164cff4512caeeb38e562b04f448c1ac1b608b2cda4abd348f91319e4e8fbb3b195ba31a8fb415ba80f0ed7c5937
+DIST stormpath-2.1.1.tar.gz 4326557 SHA256 94600e8368f2fbe06adea5fddc8f4b7a479f7a89a0a35a46f58f7c796286e5f4 SHA512 7548aff63e5f04718d4d4887a1177f6f0cf3cc8cb9588e17f7563bae9c6dc5897a968ee2c4e189b6d9100ef16ec7e34e524c4cd3c5112845c0619876ca6d5505 WHIRLPOOL 33db1d8e52d24581a1fe7220b4329479142772939d1df76d52a46d47db6219890fde3204655dd65851d43b38e2427cd32df894392948482d85554772b9f12bbf
diff --git a/dev-python/stormpath/stormpath-2.1.1.ebuild b/dev-python/stormpath/stormpath-2.1.1.ebuild
new file mode 100644
index 000000000000..539c56ce761f
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test || die "tests failed under ${EPYTYHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}