summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-29 00:52:19 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-29 00:52:59 +1000
commit7bc3ef44ab1fa22134955c90c89752ee41ba4fe1 (patch)
tree919466b7262327b8d16d0e8b305dcdc8c1755f2a
parentsys-kernel/gentoo-sources: Linux patch 3.12.59 and removal of redundant patch. (diff)
downloadgentoo-7bc3ef44ab1fa22134955c90c89752ee41ba4fe1.tar.gz
gentoo-7bc3ef44ab1fa22134955c90c89752ee41ba4fe1.tar.bz2
gentoo-7bc3ef44ab1fa22134955c90c89752ee41ba4fe1.zip
dev-qt/qtlocation: new package
Imported from qt overlay. Package-Manager: portage-2.2.28
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/metadata.xml17
-rw-r--r--dev-qt/qtlocation/qtlocation-5.6.0.ebuild30
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
new file mode 100644
index 000000000000..c55333aa514d
--- /dev/null
+++ b/dev-qt/qtlocation/Manifest
@@ -0,0 +1 @@
+DIST qtlocation-opensource-src-5.6.0.tar.xz 3076136 SHA256 360e1519d0fcafe4f86923d224e76d56dd785dfb0e1a19fd2e2b0016799653c9 SHA512 76cc7f27a043999af56f7bec408c46f0bb0709f651a3d84084f7ae92c3f50f6450420bdda31db17436111df537b94d51a9ca2819cce13ce83c538490d3f62a1d WHIRLPOOL b4bd14bb1882155ae9143d66ae99191dd95b89860ca609bbf5cffedec745f026369ce12df0bfd40c9b79d74f26036c184ebadee11dcd929a1f6a4d01634a2ab2
diff --git a/dev-qt/qtlocation/metadata.xml b/dev-qt/qtlocation/metadata.xml
new file mode 100644
index 000000000000..08d85fc4c258
--- /dev/null
+++ b/dev-qt/qtlocation/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>http://doc.qt.io/</doc>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Qt API.
+ </subslots>
+ </slots>
+</pkgmetadata>
diff --git a/dev-qt/qtlocation/qtlocation-5.6.0.ebuild b/dev-qt/qtlocation/qtlocation-5.6.0.ebuild
new file mode 100644
index 000000000000..b0d8a7717791
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="The Location module for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)