summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2017-01-07 09:15:28 -0800
committerLars Wendler <polynomial-c@gentoo.org>2017-01-07 19:47:51 +0100
commit7c17097c2266d20cce2fd8f3b05cd9c9ffbccd22 (patch)
treec32de672a8c81a689ed2ee16e451b67eedfe0f1d
parentprofiles: mask dev-libs/glib:1 for removal (diff)
downloadgentoo-7c17097c2266d20cce2fd8f3b05cd9c9ffbccd22.tar.gz
gentoo-7c17097c2266d20cce2fd8f3b05cd9c9ffbccd22.tar.bz2
gentoo-7c17097c2266d20cce2fd8f3b05cd9c9ffbccd22.zip
sys-apps/pcmciautils: flex-2.6.3 compatibility fix
Fixes yywrap errors caused by behavior changes in flex-2.6.3. Gentoo-bug: 604606 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3363
-rw-r--r--sys-apps/pcmciautils/files/pcmciautils-018_p8-flex-2.6.3-fix.patch27
-rw-r--r--sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild17
2 files changed, 37 insertions, 7 deletions
diff --git a/sys-apps/pcmciautils/files/pcmciautils-018_p8-flex-2.6.3-fix.patch b/sys-apps/pcmciautils/files/pcmciautils-018_p8-flex-2.6.3-fix.patch
new file mode 100644
index 000000000000..e30abb0d1076
--- /dev/null
+++ b/sys-apps/pcmciautils/files/pcmciautils-018_p8-flex-2.6.3-fix.patch
@@ -0,0 +1,27 @@
+--- pcmciautils-018/src/lex_config.l
++++ pcmciautils-018/src/lex_config.l
+@@ -1,8 +1,8 @@
+ /* Special state for handling include files */
+ %x src
+-%option noinput nounput
++%option noinput nounput noyywrap
+
+ %{
+ /*
+ * Startup tool for non statically mapped PCMCIA sockets
+ *
+@@ -75,14 +75,10 @@ module /* skip */ ;
+
+ . return yytext[0];
+
+ %%
+
+-#ifndef yywrap
+-int yywrap() { return 1; }
+-#endif
+-
+ /*======================================================================
+
+ Stuff to parse basic data types
+
+ ======================================================================*/
diff --git a/sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild b/sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild
index 409b157da962..c4b8e065ee12 100644
--- a/sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild
+++ b/sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils flag-o-matic linux-info toolchain-funcs udev
+EAPI=6
+inherit flag-o-matic linux-info toolchain-funcs udev
DEB_REV=${PV#*_p}
MY_PV=${PV%_p*}
@@ -51,11 +51,14 @@ pkg_setup() {
use debug && append-cppflags -DDEBUG
}
-src_prepare() {
- epatch \
- "${WORKDIR}"/debian/patches/no-modprobe-rules.patch \
- "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
+PATCHES=(
+ "${WORKDIR}"/debian/patches/no-modprobe-rules.patch
+ "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
+ "${FILESDIR}"/${P}-flex-2.6.3-fix.patch
+)
+src_prepare() {
+ default
sed -i \
-e '/CFLAGS/s:-fomit-frame-pointer::' \
-e '/dir/s:sbin:bin:g' \