summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-28 09:59:27 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-28 09:59:27 +0200
commit7c1902a79e945bbad9a35363ef7cf487fd9e0d90 (patch)
tree03f8c7de8d02c274ab7fb2e2f321d4722e70d40e
parentdev-ruby/jquery-ui-rails: add ruby23 (diff)
downloadgentoo-7c1902a79e945bbad9a35363ef7cf487fd9e0d90.tar.gz
gentoo-7c1902a79e945bbad9a35363ef7cf487fd9e0d90.tar.bz2
gentoo-7c1902a79e945bbad9a35363ef7cf487fd9e0d90.zip
dev-ruby/capistrano: add ruby23
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild4
-rw-r--r--dev-ruby/capistrano/capistrano-3.4.1.ebuild10
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild b/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
index df434debd4a0..e21143a5f4de 100644
--- a/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
+++ b/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
+USE_RUBY="ruby21 ruby22 ruby23"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
diff --git a/dev-ruby/capistrano/capistrano-3.4.1.ebuild b/dev-ruby/capistrano/capistrano-3.4.1.ebuild
index 147c14cc8a28..e272053f97be 100644
--- a/dev-ruby/capistrano/capistrano-3.4.1.ebuild
+++ b/dev-ruby/capistrano/capistrano-3.4.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
+USE_RUBY="ruby21 ruby22 ruby23"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -25,7 +25,11 @@ ruby_add_rdepend "
dev-ruby/i18n:*
!!<dev-ruby/capistrano-2.15.5-r2"
ruby_add_bdepend "
- test? ( dev-ruby/mocha:0.12 )"
+ test? ( dev-ruby/mocha:0.14 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "mocha", "~>0.14.0"' spec/spec_helper.rb || die
+}
pkg_postinst() {
einfo "Capistrano 3.1 has some breaking changes. Please check the CHANGELOG: http://goo.gl/SxB0lr"