summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-01-10 20:08:46 -0500
committerBrian Evans <grknight@gentoo.org>2018-01-10 20:08:46 -0500
commit7c68ec36294f89a4da4554dc803cfef58c7eecbb (patch)
tree4e471f0cec62556c4297dea42ecb85bf10fd5337
parentprofiles: Remove last-rited sci-electronics/cirkuit (diff)
downloadgentoo-7c68ec36294f89a4da4554dc803cfef58c7eecbb.tar.gz
gentoo-7c68ec36294f89a4da4554dc803cfef58c7eecbb.tar.bz2
gentoo-7c68ec36294f89a4da4554dc803cfef58c7eecbb.zip
www-plugins/freshplayerplugin: Version bump to 0.3.9
Closes: https://bugs.gentoo.org/641640 Closes: https://bugs.gentoo.org/642228 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--www-plugins/freshplayerplugin/Manifest1
-rw-r--r--www-plugins/freshplayerplugin/files/0.3.9-ioctl.patch11
-rw-r--r--www-plugins/freshplayerplugin/freshplayerplugin-0.3.9.ebuild74
3 files changed, 86 insertions, 0 deletions
diff --git a/www-plugins/freshplayerplugin/Manifest b/www-plugins/freshplayerplugin/Manifest
index 1f7aad93dd09..32f758906837 100644
--- a/www-plugins/freshplayerplugin/Manifest
+++ b/www-plugins/freshplayerplugin/Manifest
@@ -1,2 +1,3 @@
DIST freshplayerplugin-0.3.5.tar.gz 781003 BLAKE2B 9874f07905a277c95374a697397dc9b3661cdba40b39ee74702d4ec67a0447d13cc2a187c695b47be9f922177b37bdf5fff8ebb9dd57b709f884ffa3db0da54d SHA512 dd447db4cbfdb80b89ff42894099971c100023d19fe5fbad023d5ac1afa827fdc5a169a03f4702ffda3cf6e0dd9c63217b68d97d047ac43afc22f488020a0ba0
DIST freshplayerplugin-0.3.7.tar.gz 789974 BLAKE2B 0217e3431164e9dfce4ec21f07331aea4b5841b963c51c258f10c68d8089b8f860364d58af533f3724f8759b8d6381cba950f174b2ca3f0a7b59c581192b5a47 SHA512 9ef534b873833d69caa86a5702ad6150e4aa2fe399159a550b6cb0ebad2754d25e185c54b6285f6f50913c5595c5b460ce3e0d21ac45f0d25793805463ce1d5d
+DIST freshplayerplugin-0.3.9.tar.gz 790261 BLAKE2B 88526c01e7a06c7b295e5a7652602eb661097f869b30c8fd0978a4e03adea9d1fa75d35e5e9c0751d786c04f0247fc292aa0c1857cf1fa575eb0b11499bec7fc SHA512 999d7c223dd493e43a0fa7874371c7b781fe5273b2661fc30f814832b4aafd23f297795b644f58553107ef962ca17ce58fb39a637d1ab7bdf470cd33e0b19cf8
diff --git a/www-plugins/freshplayerplugin/files/0.3.9-ioctl.patch b/www-plugins/freshplayerplugin/files/0.3.9-ioctl.patch
new file mode 100644
index 000000000000..112b839016f9
--- /dev/null
+++ b/www-plugins/freshplayerplugin/files/0.3.9-ioctl.patch
@@ -0,0 +1,11 @@
+diff -aurN a/src/ppb_video_capture.c b/src/ppb_video_capture.c
+--- a/src/ppb_video_capture.c 2017-12-23 09:34:01.000000000 -0500
++++ b/src/ppb_video_capture.c 2018-01-10 20:03:05.498415644 -0500
+@@ -75,6 +75,7 @@
+
+ #if !HAVE_LIBV4L2
+ // define simple wrappers, if libv4l2 is not used
++#include <sys/ioctl.h>
+ static
+ ssize_t
+ v4l2_read(int fd, void *buffer, size_t n)
diff --git a/www-plugins/freshplayerplugin/freshplayerplugin-0.3.9.ebuild b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.9.ebuild
new file mode 100644
index 000000000000..4348e877cbfe
--- /dev/null
+++ b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+LICENSE="MIT"
+HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
+DESCRIPTION="PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT=0
+IUSE="gles2 jack libav libressl pulseaudio v4l vaapi vdpau"
+
+KEYWORDS="~amd64"
+
+HWDEC_DEPEND="
+ libav? ( media-video/libav:0=[vaapi?,vdpau?] )
+ !libav? ( media-video/ffmpeg:0=[vaapi?,vdpau?] )
+ x11-libs/libva:=
+ x11-libs/libvdpau
+"
+
+COMMON_DEPEND="
+ dev-libs/glib:2=
+ dev-libs/icu:0=
+ dev-libs/libevent:=[threads]
+ media-libs/alsa-lib:=
+ media-libs/freetype:2=
+ media-libs/mesa:=[egl,gles2?]
+ x11-libs/cairo:=[X]
+ x11-libs/libXcursor:=
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/libdrm:=
+ x11-libs/pango:=[X]
+ jack? (
+ media-sound/jack-audio-connection-kit
+ media-libs/soxr
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ v4l? ( media-libs/libv4l:0= )
+ vaapi? ( ${HWDEC_DEPEND} )
+ vdpau? ( ${HWDEC_DEPEND} )
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/ragel
+ virtual/pkgconfig
+ "
+RDEPEND="${COMMON_DEPEND}
+ www-plugins/adobe-flash:22[abi_x86_64,ppapi(+)]
+ "
+
+PATCHES=( "${FILESDIR}/0.3.5-cmake.patch" "${FILESDIR}/0.3.9-ioctl.patch" )
+DOCS=( ChangeLog data/freshwrapper.conf.example README.md )
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_JACK=$(usex jack)
+ -DWITH_PULSEAUDIO=$(usex pulseaudio)
+ -DWITH_GLES2=$(usex gles2)
+ -DWITH_LIBV4L2=$(usex v4l)
+ -DCMAKE_SKIP_RPATH=1
+ )
+ if use vaapi || use vdpau ; then
+ mycmakeargs+=( -DWITH_HWDEC=1 )
+ else
+ mycmakeargs+=( -DWITH_HWDEC=0 )
+ fi
+ cmake-utils_src_configure
+}