summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-28 17:15:46 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-28 17:15:46 +0100
commit7d24a3eeb9b89ec1cebb5399f77e10416c8558a8 (patch)
treec1afc781a8fd8172b735d682cfe06a3fe3bfc723
parentdev-python/rootpy: Remove Py2 (diff)
downloadgentoo-7d24a3eeb9b89ec1cebb5399f77e10416c8558a8.tar.gz
gentoo-7d24a3eeb9b89ec1cebb5399f77e10416c8558a8.tar.bz2
gentoo-7d24a3eeb9b89ec1cebb5399f77e10416c8558a8.zip
dev-python/rpyc: Remove Py2
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/rpyc/rpyc-3.4.4.ebuild7
-rw-r--r--dev-python/rpyc/rpyc-4.0.2.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/rpyc/rpyc-3.4.4.ebuild b/dev-python/rpyc/rpyc-3.4.4.ebuild
index 0cf647f2ebaa..e08292707e8c 100644
--- a/dev-python/rpyc/rpyc-3.4.4.ebuild
+++ b/dev-python/rpyc/rpyc-3.4.4.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1
DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
HOMEPAGE="https://rpyc.readthedocs.io/en/latest/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+
RDEPEND="dev-python/plumbum"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/rpyc/rpyc-4.0.2.ebuild b/dev-python/rpyc/rpyc-4.0.2.ebuild
index f3e1ff38ded2..5132a2d564b4 100644
--- a/dev-python/rpyc/rpyc-4.0.2.ebuild
+++ b/dev-python/rpyc/rpyc-4.0.2.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1
DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
HOMEPAGE="https://rpyc.readthedocs.io/en/latest/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
RDEPEND="dev-python/plumbum[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"