summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2015-09-22 09:03:38 +0200
committerTupone Alfredo <tupone@gentoo.org>2015-09-22 09:04:46 +0200
commit7d34e2550629de942f05ab332bdb1bc365b82506 (patch)
tree46d37667b5e83b4931a97f1df3f25e5f98155dc3
parentdev-python/pytest-cov: Drop restriction on dev version (diff)
downloadgentoo-7d34e2550629de942f05ab332bdb1bc365b82506.tar.gz
gentoo-7d34e2550629de942f05ab332bdb1bc365b82506.tar.bz2
gentoo-7d34e2550629de942f05ab332bdb1bc365b82506.zip
games-action/garden: Build with gcc:5.2
Package-Manager: portage-2.2.20.1
-rw-r--r--games-action/garden/files/garden-1.0.9-gcc52.patch20
-rw-r--r--games-action/garden/garden-1.0.9.ebuild3
2 files changed, 22 insertions, 1 deletions
diff --git a/games-action/garden/files/garden-1.0.9-gcc52.patch b/games-action/garden/files/garden-1.0.9-gcc52.patch
new file mode 100644
index 000000000000..60f927217c6e
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-gcc52.patch
@@ -0,0 +1,20 @@
+--- src/stuff.c.old 2015-09-22 08:57:21.482794770 +0200
++++ src/stuff.c 2015-09-22 08:58:22.567815095 +0200
+@@ -52,7 +52,7 @@
+ float cos_table[ANGLE_1];
+ float sin_table[ANGLE_1];
+
+-inline int xpart (int angle, int length);
++extern inline int xpart (int angle, int length);
+
+ void init_trig (void)
+ {
+@@ -72,7 +72,7 @@
+ return (cos_table[angle & 1023] * length);
+ }
+
+-inline int ypart (int angle, int length)
++extern inline int ypart (int angle, int length)
+ {
+ return (sin_table[angle & 1023] * length);
+ }
diff --git a/games-action/garden/garden-1.0.9.ebuild b/games-action/garden/garden-1.0.9.ebuild
index 62df12c7f80a..63eb620271a3 100644
--- a/games-action/garden/garden-1.0.9.ebuild
+++ b/games-action/garden/garden-1.0.9.ebuild
@@ -20,7 +20,8 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-dash.patch \
- "${FILESDIR}"/${P}-resources.patch
+ "${FILESDIR}"/${P}-resources.patch \
+ "${FILESDIR}"/${P}-gcc52.patch
eautoreconf
}