summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-08-09 23:02:07 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-08-09 23:02:23 +0200
commit7d3d64e2b2c2610a47b3b3e37e8908e61c54b341 (patch)
treebd843a22141181556b2a4c7f9986bebc63aa6ef9
parentsys-apps/pkgcore: bump snakeoil depbound for py3.11 (diff)
downloadgentoo-7d3d64e2b2c2610a47b3b3e37e8908e61c54b341.tar.gz
gentoo-7d3d64e2b2c2610a47b3b3e37e8908e61c54b341.tar.bz2
gentoo-7d3d64e2b2c2610a47b3b3e37e8908e61c54b341.zip
x11-plugins/wmsysmon: add 0.8.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmsysmon/Manifest1
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmsysmon/Manifest b/x11-plugins/wmsysmon/Manifest
index 12e312cd5b7f..3f36f55d0ec3 100644
--- a/x11-plugins/wmsysmon/Manifest
+++ b/x11-plugins/wmsysmon/Manifest
@@ -1 +1,2 @@
DIST wmsysmon-0.7.8.tar.gz 23533 BLAKE2B 830edc78222e8997c6ee23bdd9fcb28729e9b80d92b07f70a53d841065b7377f5c450024c511b4faa92043bd45aa0cc92e89ff900d7d4a53d3c9f4b57b4e6e7e SHA512 b1afd176851e8f89896e39b55d24d6efeb97eb5fdbb9c181cb030320445f1d8b22d31073edc615e6b47b91fd133b381f00b612901c8b312e7da404a4746bb97c
+DIST wmsysmon-0.8.0.tar.gz 21262 BLAKE2B 50c7e3149fbad711f7505558549eadede78abf4f52d5c2c6eff0bd74bbb9838f85b78d73a7021a3baf9776cdccfb2b8e621de897fdafe5a7af71cd8518933852 SHA512 af9f939de5031387abf31d7ad9b4f767056a5f0d1494ee95476fb6c3bafab95ffe78148da74bf004b40a1e0d4ace9616c272bce0f4900491c8983c34531c29e7
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild
new file mode 100644
index 000000000000..70a26acef4a9
--- /dev/null
+++ b/x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp to monitor: CPU, Memory, Uptime, IRQs, Paging and Swap activity"
+HOMEPAGE="https://github.com/voyageur/wmsysmon"
+SRC_URI="https://github.com/voyageur/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+DOCS=( ../ChangeLog ../README )
+S=${WORKDIR}/${P}/src
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wmsysmon
+ einstalldocs
+}