summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-18 16:55:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-18 16:57:48 +0200
commit7dc7a02ae80365e9b7765fdaa7f0b643bd83f53e (patch)
tree40c81ae25c879c18369c180e0795361b32c5b9b1
parentdev-libs/libgcrypt: amd64 stable wrt bug #591534 (diff)
downloadgentoo-7dc7a02ae80365e9b7765fdaa7f0b643bd83f53e.tar.gz
gentoo-7dc7a02ae80365e9b7765fdaa7f0b643bd83f53e.tar.bz2
gentoo-7dc7a02ae80365e9b7765fdaa7f0b643bd83f53e.zip
Revert "media-libs/libmtp: Removed old."
This reverts commit 74c27b598d9a66ba77f0b9757d023a126981b13c. This fixes QA issues with gnome-base/gvfs
-rw-r--r--media-libs/libmtp/Manifest3
-rw-r--r--media-libs/libmtp/libmtp-1.1.10.ebuild68
-rw-r--r--media-libs/libmtp/libmtp-1.1.8.ebuild74
-rw-r--r--media-libs/libmtp/libmtp-1.1.9.ebuild68
4 files changed, 213 insertions, 0 deletions
diff --git a/media-libs/libmtp/Manifest b/media-libs/libmtp/Manifest
index 54e96ea4d621..fa4366880daa 100644
--- a/media-libs/libmtp/Manifest
+++ b/media-libs/libmtp/Manifest
@@ -1,2 +1,5 @@
+DIST libmtp-1.1.10.tar.gz 787654 SHA256 1eee8d4c052fe29e58a408fedc08a532e28626fa3e232157abd8fca063c90305 SHA512 7b0d06ac11a7476b6d8c84eb452c4abe08f8f61dafd8b1900e87f550665d5d3add182bbcba6d774426c8c9f6e978cef499a1f0d09283e5d6d02b812eb2eb3072 WHIRLPOOL 77df823382cb5756db4967e9131877888491eb11b9ef2ffdc8fecbb55a5f1df70223be54ef816899ddb0997bc73c8f445e25f2f8a22675da680d3017d2eb08df
DIST libmtp-1.1.11.tar.gz 788911 SHA256 15d96dff79a4f7ad14338894a4096d4ac584c6ad25fdcca955bc4726303287e9 SHA512 966d5d831695dc02411fbe0a153873d9e5604a00e75bf0d4cc1a957887a2e7656c82209f5bf86150f7b9af037d66a96b3e3523e16d5b52ae013b835febf622c9 WHIRLPOOL 16e31709054de63d954c691b6396d7e1ad23c3327228188a5b918326a2ac9458d5701dabd73f86568dc5d7cd8512cbe2ddbaccb96d1e31d7e2c69ff0ac14b9a5
DIST libmtp-1.1.12.tar.gz 776555 SHA256 cdf59e816c6cda3e908a876c7fb42943f40b85669aea0029a1ca431c89afa1a0 SHA512 2fff8f6653aa1fa6d7a545fc4f0ae8cb3e54fdb4486a0f065b733ffb5c33f994f66067a697ffe52fe65fb39ffe2bacc418543f84e504e18f443e3c563a116c4f WHIRLPOOL 3825139caa3304be041f0a786e3c871000b47b568cfa0015edecb2ce9ff9e377817abceabe0a81fce368d76efa03e2e9dce2490d57dd9e41f133e94b86a29c67
+DIST libmtp-1.1.8.tar.gz 757109 SHA256 3f9e87536aa40e560d0c153a505e38096b1df5ea15fad783691e9a8ca4dd2282 SHA512 34952fbe1ae1dcee456f4fc0d6208cf18e3ced22891bb748350927f06ee433f806e8339d6275085e70b6fd09a43eb0f18ac617e564c8d8162671245ecf0b8904 WHIRLPOOL 5ab0df9b566b7fe3193b0a09a0792eb2634d0775a8ee9a9358d13b2aeba4c82816f5ecb5e5d7355ed338d6171259b7a5c9802b4bc8ea2b0de3d4bbbd1aa8050c
+DIST libmtp-1.1.9.tar.gz 760593 SHA256 23f1d3c0b54107388bf2824d56415e9e087c980c86e5d179865652c022b6b189 SHA512 6be9f14602b05830ec01defaeb0f237ac4d021f76f4003d7178eda00d8bf86d7fbbeba0053dc111d2ab9eb32f1603c2dc4f2bc128f4cbe4819228486b9b85513 WHIRLPOOL d357c949907b69f3a40291a79e05cc75790d86abb7fa0ea787c5ef0cd666b7f9888f9441f9893824520345d25799142f70c0ba0b773267fb9b374bb0d8b833e6
diff --git a/media-libs/libmtp/libmtp-1.1.10.ebuild b/media-libs/libmtp/libmtp-1.1.10.ebuild
new file mode 100644
index 000000000000..9cf6cbc1245b
--- /dev/null
+++ b/media-libs/libmtp/libmtp-1.1.10.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev user
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/${PN}/code"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="An implementation of Microsoft's Media Transfer Protocol (MTP)"
+HOMEPAGE="http://libmtp.sourceforge.net/"
+
+LICENSE="LGPL-2.1" # LGPL-2+ and LGPL-2.1+ ?
+SLOT="0/9" # Based on SONAME of libmtp shared library
+IUSE="+crypt doc examples static-libs"
+
+RDEPEND="virtual/libusb:1
+ crypt? ( >=dev-libs/libgcrypt-1.5.4:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ DOCS="AUTHORS README TODO"
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # ChangeLog says "RETIRING THIS FILE ..pause.. GIT" (Last entry from start of 2011)
+ rm -f ChangeLog
+
+ if [[ ${PV} == 9999* ]]; then
+ local crpthf=config.rpath
+ local crpthd=/usr/share/gettext/${crpthf}
+ if has_version '>sys-devel/gettext-0.18.3' && [[ -e ${crpthd} ]]; then
+ cp "${crpthd}" .
+ else
+ touch ${crpthf} # This is from upstream autogen.sh
+ fi
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable crypt mtpz) \
+ --with-udev="$(get_udevdir)" \
+ --with-udev-group=plugdev \
+ --with-udev-mode=0660
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,sh}
+ fi
+}
diff --git a/media-libs/libmtp/libmtp-1.1.8.ebuild b/media-libs/libmtp/libmtp-1.1.8.ebuild
new file mode 100644
index 000000000000..d2a84774bdb5
--- /dev/null
+++ b/media-libs/libmtp/libmtp-1.1.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/${PN}/code"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 ~arm hppa ia64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+inherit eutils udev user
+
+DESCRIPTION="An implementation of Microsoft's Media Transfer Protocol (MTP)"
+HOMEPAGE="http://libmtp.sourceforge.net/"
+
+LICENSE="LGPL-2.1" # LGPL-2+ and LGPL-2.1+ ?
+SLOT="0/9" # Based on SONAME of libmtp shared library
+IUSE="+crypt doc examples static-libs"
+
+RDEPEND="virtual/libusb:1
+ crypt? ( >=dev-libs/libgcrypt-1.5.4:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ DOCS="AUTHORS README TODO"
+ enewgroup plugdev
+}
+
+src_unpack() {
+ [[ ${PV} == 9999* ]] && git-r3_src_unpack
+ default_src_unpack
+}
+
+src_prepare() {
+ # ChangeLog says "RETIRING THIS FILE ..pause.. GIT" (Last entry from start of 2011)
+ rm -f ChangeLog
+
+ if [[ ${PV} == 9999* ]]; then
+ local crpthf=config.rpath
+ local crpthd=/usr/share/gettext/${crpthf}
+ if has_version '>sys-devel/gettext-0.18.3' && [[ -e ${crpthd} ]]; then
+ cp "${crpthd}" .
+ else
+ touch ${crpthf} # This is from upstream autogen.sh
+ fi
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable crypt mtpz) \
+ --with-udev="$(get_udevdir)" \
+ --with-udev-group=plugdev \
+ --with-udev-mode=0660
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,sh}
+ fi
+}
diff --git a/media-libs/libmtp/libmtp-1.1.9.ebuild b/media-libs/libmtp/libmtp-1.1.9.ebuild
new file mode 100644
index 000000000000..9cf6cbc1245b
--- /dev/null
+++ b/media-libs/libmtp/libmtp-1.1.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev user
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/${PN}/code"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="An implementation of Microsoft's Media Transfer Protocol (MTP)"
+HOMEPAGE="http://libmtp.sourceforge.net/"
+
+LICENSE="LGPL-2.1" # LGPL-2+ and LGPL-2.1+ ?
+SLOT="0/9" # Based on SONAME of libmtp shared library
+IUSE="+crypt doc examples static-libs"
+
+RDEPEND="virtual/libusb:1
+ crypt? ( >=dev-libs/libgcrypt-1.5.4:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ DOCS="AUTHORS README TODO"
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # ChangeLog says "RETIRING THIS FILE ..pause.. GIT" (Last entry from start of 2011)
+ rm -f ChangeLog
+
+ if [[ ${PV} == 9999* ]]; then
+ local crpthf=config.rpath
+ local crpthd=/usr/share/gettext/${crpthf}
+ if has_version '>sys-devel/gettext-0.18.3' && [[ -e ${crpthd} ]]; then
+ cp "${crpthd}" .
+ else
+ touch ${crpthf} # This is from upstream autogen.sh
+ fi
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable crypt mtpz) \
+ --with-udev="$(get_udevdir)" \
+ --with-udev-group=plugdev \
+ --with-udev-mode=0660
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,sh}
+ fi
+}