summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-25 18:20:16 +0100
committerPacho Ramos <pacho@gentoo.org>2015-10-25 18:20:16 +0100
commit7e7b709a15ea8689b1ba292bf296786ca7aaf10a (patch)
tree46e58c749af19d42019b7a03d4969449e5c2a7bb
parentsci-geosciences/opencpn-plugin-climatology: Support wxGTK:3.0 (diff)
downloadgentoo-7e7b709a15ea8689b1ba292bf296786ca7aaf10a.tar.gz
gentoo-7e7b709a15ea8689b1ba292bf296786ca7aaf10a.tar.bz2
gentoo-7e7b709a15ea8689b1ba292bf296786ca7aaf10a.zip
sci-geosciences/opencpn-plugin-launcher: Support wxGTK:3.0
Package-Manager: portage-2.2.23
-rw-r--r--sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.0-r1.ebuild b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.0-r1.ebuild
new file mode 100644
index 000000000000..5957f28d358c
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+inherit cmake-utils wxwidgets
+
+MY_PN="launcher_pi"
+
+DESCRIPTION="Launcher Plugin for OpenCPN"
+HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
+SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sci-geosciences/opencpn-4.0.0
+ sys-devel/gettext
+ x11-libs/wxGTK:${WX_GTK_VER}
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}