summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-01-11 14:05:41 +0300
committerSergei Trofimovich <slyfox@gentoo.org>2017-01-11 14:05:55 +0300
commit7eaff6c31b22e5345e03702148ef52866c8ba283 (patch)
tree42c35d7582177cc66194c400f3f41dd92766648d
parentsys-apps/minised: clean up old. (diff)
downloadgentoo-7eaff6c31b22e5345e03702148ef52866c8ba283.tar.gz
gentoo-7eaff6c31b22e5345e03702148ef52866c8ba283.tar.bz2
gentoo-7eaff6c31b22e5345e03702148ef52866c8ba283.zip
dev-util/radare2: backport eroen's openssl-1.1.0c fix
Bug: https://bugs.gentoo.org/604576 Package-Manager: Portage-2.3.3_p18, Repoman-2.3.1_p11
-rw-r--r--dev-util/radare2/files/radare2-1.1.0-openssl-1.1.0c.patch31
-rw-r--r--dev-util/radare2/radare2-1.1.0.ebuild3
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-util/radare2/files/radare2-1.1.0-openssl-1.1.0c.patch b/dev-util/radare2/files/radare2-1.1.0-openssl-1.1.0c.patch
new file mode 100644
index 000000000000..28e2f55126f8
--- /dev/null
+++ b/dev-util/radare2/files/radare2-1.1.0-openssl-1.1.0c.patch
@@ -0,0 +1,31 @@
+commit ecd8cf26c2647a1f455595209fcf2d6bfb72240f
+Author: eroen <eroen@users.noreply.github.com>
+Date: Tue Jan 3 23:45:07 2017 +0100
+
+ Disable deprecated initialization for openssl 1.1.0 (#6423)
+
+ Openssl 1.1.0 handles this initialization internally. Leaving the calls in
+ place causes "undefined reference" errors if openssl was built with
+ `--api=1.1.0`.
+
+ X-Gentoo-Bug: 604576
+ X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=604576
+
+diff --git a/libr/socket/socket.c b/libr/socket/socket.c
+index 1e30120fb..1ba87e77e 100755
+--- a/libr/socket/socket.c
++++ b/libr/socket/socket.c
+@@ -116,11 +116,13 @@ R_API RSocket *r_socket_new (int is_ssl) {
+ s->sfd = NULL;
+ s->ctx = NULL;
+ s->bio = NULL;
++#if OPENSSL_VERSION_NUMBER < 0x1010000fL
+ if (!SSL_library_init ()) {
+ r_socket_free (s);
+ return NULL;
+ }
+ SSL_load_error_strings ();
++#endif
+ }
+ #endif
+ return s;
diff --git a/dev-util/radare2/radare2-1.1.0.ebuild b/dev-util/radare2/radare2-1.1.0.ebuild
index ed05b063b159..a7480ac46e88 100644
--- a/dev-util/radare2/radare2-1.1.0.ebuild
+++ b/dev-util/radare2/radare2-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
"
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.9.9-nogit.patch
+ epatch "${FILESDIR}"/${P}-openssl-1.1.0c.patch
}
src_configure() {