summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-29 09:19:14 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-29 11:59:47 +0100
commit7ecb3b1ecd78c57ac5c43e8658cf2b88a78ca8ad (patch)
treed3dcb9c16b4869c000e83bd48bf930af55a461c4
parentdev-python/hypothesis: Drop redudant versions (diff)
downloadgentoo-7ecb3b1ecd78c57ac5c43e8658cf2b88a78ca8ad.tar.gz
gentoo-7ecb3b1ecd78c57ac5c43e8658cf2b88a78ca8ad.tar.bz2
gentoo-7ecb3b1ecd78c57ac5c43e8658cf2b88a78ca8ad.zip
dev-python/hypothesis: Bump to 4.50.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-4.50.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 67e487801735..64e7af078457 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-3.74.3.tar.gz 552616 BLAKE2B e19a0991e7ae2fa6208c81d336cc
DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad2582eb23bd8ab2e218f1bde82ba1639123f32e8c147313c22b15781d8986574813b5f6eb7c23ce28367e86bb304d33a23f179fa0 SHA512 7d9788b351196fc20e66e210b7d60b4ddb1507b85cf5a29de228600e07f676ccd1352f5d2ab0820b3c8c1a1e8ff145225f00a25aec5f325cc7405ffd0dfcd9f7
DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d91eda525f8ef51eb893f1f8e5224cead8572f3c06f6a4bb345c123e56ed06d0676c85dc4477a80e54480baa6bd9f5f2bc069e SHA512 bebc5da337fa74a75d08cb57531c2f6b8ba1ab16d1a3d9be8348cd56ada1ab25a34e3b812a4aa71bf172bc97ebc8df0accdad37466f9162c3f8f2a8edbea9da9
DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b38858d47fddba613ce37eb9a9554afa3c189776e9172965dd31f8497747ac13b2ab1d34ee6de8671646972e71b82c5260db489b9a SHA512 9b6920181dca75b9e551ae5e598101f35cfc26e9e3a1b20cab652c151bc6355413d0c9602d3242fb23f808ab00335793009df938d55ee19a6af1ce2a8b085e3c
+DIST hypothesis-python-4.50.1.tar.gz 6811489 BLAKE2B 26efeb6b648f494e5d6c7b36f6c32c92bb7bf6ae0ae776d39d9e4a815122cb3832fc8b035823b7e11de41afa0b529b9ed38ee63b0a3cf0aafa3bded50fc04abb SHA512 b6d2799b2ab8e5809f9ac7bb910bd6844c853a50e1bdacb77afc4c3a09631cd626036dd4edf3b1e211bec4982feeb07c2273ad1a4029b737dc188b0d7c5a3beb
diff --git a/dev-python/hypothesis/hypothesis-4.50.1.ebuild b/dev-python/hypothesis/hypothesis-4.50.1.ebuild
new file mode 100644
index 000000000000..3def9e851218
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-4.50.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local pyver=$(python_is_python3 && echo 3 || echo 2)
+ pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}