summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2017-08-30 10:01:51 -0700
committerDaniel Campbell <zlg@gentoo.org>2017-08-30 10:19:10 -0700
commit7fed3b7bd8ce67da8fd79bbf1845fe6a32933dda (patch)
tree641f54c311e02af56ec261bd9dac33fc5a6147de
parentmedia-gfx/gimp: Fix src_test (bug #629264) (diff)
downloadgentoo-7fed3b7bd8ce67da8fd79bbf1845fe6a32933dda.tar.gz
gentoo-7fed3b7bd8ce67da8fd79bbf1845fe6a32933dda.tar.bz2
gentoo-7fed3b7bd8ce67da8fd79bbf1845fe6a32933dda.zip
net-im/toxic: version bump to 0.8.0
Version 0.8.0 brings Python 3.x support. Reviewed-by: Mike Gilbert <floppym@gentoo.org> Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--net-im/toxic/Manifest1
-rw-r--r--net-im/toxic/metadata.xml3
-rw-r--r--net-im/toxic/toxic-0.8.0.ebuild65
3 files changed, 68 insertions, 1 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
index 68d914717052..c56d07a007dd 100644
--- a/net-im/toxic/Manifest
+++ b/net-im/toxic/Manifest
@@ -1,2 +1,3 @@
DIST toxic-0.7.1.tar.gz 1137112 SHA256 414ca2cd369e277872c7248c43f82afa0ac2f6c8fa5fc8e93f7c3e8ab6d11b9c SHA512 c304b07a67ed27a25394590eb8759b5dd957605be4eb9e64590d4580da0977e1cd201e8b95ae1b31e995772560510ceb0643028696e2df69e1f5d0dff575b553 WHIRLPOOL 228193bb78bf38bd5f5f5ff371a87f12561edcb5729337b58198df36e5ec55b99f2c2ca84f5b471846e7f84445f1c5181c5fa71ff287f62d5e34f833a45747d6
DIST toxic-0.7.2.tar.gz 1136947 SHA256 a2962aca766caf84b52a52e9a5ce2276a9d3906685f565d2a00551e7c2916c59 SHA512 cf3fd0afdc63aa4d2039e08a8f9f32a042a6412f0a242823205fcf058f56e732468389d4bdf614ded8b0d9704b05a315044ee216edd51546501a24be0b6d5b26 WHIRLPOOL 47b5ee57a38084ea7dcff12cac77b05a2d8d486f0ecaffe5e5db11825338a785a96563e10abcb788accea527d2da6f690b326628dd09601d2bf002f69cc60de3
+DIST toxic-0.8.0.tar.gz 1145799 SHA256 4078167ff09a94a78cd46d55163524b0a6692b56a74458c99093b84316a6c604 SHA512 3c59edb61b1bcdbfa3a8391a1a1ceccc6c9c38b49c1709813d60480b180fb39607806116b9dcd1de35ebb02e23e95d78c8191f04a4875e06e27fa43bc9800b33 WHIRLPOOL 3b99ab4720c5360ce531db210a23e830eb99be70836fb7ef9d7604b526f26a7fd92dfd4ab26d1cbdb642371cc98a646aad9f4527b7c2c9f2da50f2347ab7a74e
diff --git a/net-im/toxic/metadata.xml b/net-im/toxic/metadata.xml
index 4032c8812a4f..4a6dc2b64633 100644
--- a/net-im/toxic/metadata.xml
+++ b/net-im/toxic/metadata.xml
@@ -8,7 +8,7 @@
<upstream>
<maintainer>
<email>jfreegman@tox.chat</email>
- <name>JFreegman</name>
+ <name>Jakob Kreuze</name>
</maintainer>
<remote-id type="github">jfreegman/toxic</remote-id>
</upstream>
@@ -18,5 +18,6 @@
<use>
<flag name="notifications">Enables desktop notifications with libnotify</flag>
<flag name="av">Enables audio calling and/or audio notifications</flag>
+ <flag name="qrcode">Enables QR code support</flag>
</use>
</pkgmetadata>
diff --git a/net-im/toxic/toxic-0.8.0.ebuild b/net-im/toxic/toxic-0.8.0.ebuild
new file mode 100644
index 000000000000..c8827675bcf8
--- /dev/null
+++ b/net-im/toxic/toxic-0.8.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+
+inherit python-single-r1
+
+DESCRIPTION="A curses-based client for Tox."
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X +av notifications +python +qrcode"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ net-libs/tox:0/0.1[av?]
+ dev-libs/libconfig
+ net-misc/curl:0=
+ sys-libs/ncurses:0=
+ av? ( media-libs/openal media-libs/freealut )
+ notifications? ( x11-libs/libnotify )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? ( media-gfx/qrencode )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ if ! use av; then
+ export DISABLE_AV=1
+ export DISABLE_SOUND_NOTIFY=1
+ fi
+ if ! use X; then
+ export DISABLE_X11=1
+ fi
+ if ! use notifications; then
+ export DISABLE_DESKTOP_NOTIFY=1
+ fi
+ if ! use qrcode; then
+ export DISABLE_QRPNG=1
+ fi
+ if use python; then
+ export ENABLE_PYTHON=1
+ fi
+ sed -i \
+ -e "s,/usr/local,${EPREFIX}/usr,g" \
+ cfg/global_vars.mk || die "PREFIX sed failed"
+}
+
+src_install() {
+ default
+ if ! use av; then
+ rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
+ fi
+}