summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-07-30 22:26:42 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-07-30 22:41:02 -0500
commit80165763f886ad926e094441aca96b9be3edaee1 (patch)
tree7e99eb6d5a0df2b9341f43d82f1c88850a5a0f53
parentmedia-gfx/gthumb: bump to 3.4.5 (diff)
downloadgentoo-80165763f886ad926e094441aca96b9be3edaee1.tar.gz
gentoo-80165763f886ad926e094441aca96b9be3edaee1.tar.bz2
gentoo-80165763f886ad926e094441aca96b9be3edaee1.zip
dev-util/gertty: 1.5.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-util/gertty/Manifest1
-rw-r--r--dev-util/gertty/gertty-1.5.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/gertty/Manifest b/dev-util/gertty/Manifest
index f533b5d3a548..27dd9f12e6c0 100644
--- a/dev-util/gertty/Manifest
+++ b/dev-util/gertty/Manifest
@@ -1,2 +1,3 @@
DIST gertty-1.3.2.tar.gz 92553 SHA256 653376fa55a75be16aeca4e9eb0286f245745a87f977b780b423b74b56df2c74 SHA512 b68acb801ceb225fe86d62015fd89bce7ebe34219dbb2f7fe10d991ff06b558a5ed3512e6435ef3ce13324841c473dbec565c7bef23e01567f5bdcbb6aba9136 WHIRLPOOL 2016e2b09343612968c9984e05a3b9da4d1ebf65b2029a15a429015d9cb83c13ceeca3f50d2cb285da3ae6227f7eb894d597cef0ddb945f23b520ea67ffb572a
DIST gertty-1.4.0.tar.gz 115581 SHA256 9982be2016cc1111bd4c2edb091fde2d0196f36f418d18fa0365a0282f61c4da SHA512 9abba6271d3ec95938f07ab4ee76f0b539a7ce7f0bbf9c08509fe9516c14f99ccb7b439d29a30bff6dca99bf39788dc803cd8aed3cc03b531678225fa41102d9 WHIRLPOOL d0efc9b55be12458b835eedc9f21053dfd508ca55e024f42e4a6d358631f4082788bd02ef8070788a8b37525857615cab03a59d7b43629737131b106da2e3dbf
+DIST gertty-1.5.0.tar.gz 119784 SHA256 290e4dc688b2f4d6886f0493b861c01a8c0419dd6c49a925fba0b936d3f28b23 SHA512 bc47817a3ba9ccce298ee1a646cb43f8a57e9a57a40d898859836b3171abd0cf3c682a5f5811cf3d987a17dbf00dd6706a5dbc5a6a35f1d5ff3a217c68187cda WHIRLPOOL 53a31e536de669f1ad3d041a98542a27580822c0781fd3b15124b70b80bc0e5b7b4708ab8ed49e53a53436e784098d2dfdf1208d1ead155710afd500492f602f
diff --git a/dev-util/gertty/gertty-1.5.0.ebuild b/dev-util/gertty/gertty-1.5.0.ebuild
new file mode 100644
index 000000000000..c2ffc03b5758
--- /dev/null
+++ b/dev-util/gertty/gertty-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Gertty is a console-based interface to the Gerrit Code Review system."
+HOMEPAGE="https://pypi.python.org/pypi/gertty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
+ !~dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/git-python-0.3.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+ dev-python/ordereddict[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"