summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-02-11 12:21:45 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2018-02-11 12:34:30 -0700
commit811e64445c4c55cc76aac97bd1e52d060608a5eb (patch)
treec753e0d40650515643e0edda1aa3c2f796278f96
parentdev-ruby/ruby-termios: add ruby25 (diff)
downloadgentoo-811e64445c4c55cc76aac97bd1e52d060608a5eb.tar.gz
gentoo-811e64445c4c55cc76aac97bd1e52d060608a5eb.tar.bz2
gentoo-811e64445c4c55cc76aac97bd1e52d060608a5eb.zip
media-libs/gexiv2: Add dependency
We are using autoreconf which requires gobject-introspection-common as an additional dependency. This change adds this missing DEPEND. Closes: https://bugs.gentoo.org/636088 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.3-r1.ebuild53
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.6.ebuild3
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.8.ebuild1
3 files changed, 56 insertions, 1 deletions
diff --git a/media-libs/gexiv2/gexiv2-0.10.3-r1.ebuild b/media-libs/gexiv2/gexiv2-0.10.3-r1.ebuild
new file mode 100644
index 000000000000..fc6047cfb1f1
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.10.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit eutils multilib python-r1 toolchain-funcs versionator xdg-utils
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="introspection python static-libs"
+
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.1:2
+ >=media-gfx/exiv2-0.21:0=
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig"
+
+src_prepare() {
+ xdg_environment_reset
+ tc-export CXX
+ epatch "${FILESDIR}/${P}-exiv-0.26.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+
+ use static-libs || prune_libtool_files --modules
+}
diff --git a/media-libs/gexiv2/gexiv2-0.10.6.ebuild b/media-libs/gexiv2/gexiv2-0.10.6.ebuild
index 73d79469fb5b..4adf9967d4d8 100644
--- a/media-libs/gexiv2/gexiv2-0.10.6.ebuild
+++ b/media-libs/gexiv2/gexiv2-0.10.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,6 +28,7 @@ RDEPEND="${PYTHON_DEPS}
>=media-gfx/exiv2-0.21:0=
introspection? ( dev-libs/gobject-introspection:= )"
DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
virtual/pkgconfig"
src_prepare() {
diff --git a/media-libs/gexiv2/gexiv2-0.10.8.ebuild b/media-libs/gexiv2/gexiv2-0.10.8.ebuild
index 1ace566e3332..f92ae0bd0ad4 100644
--- a/media-libs/gexiv2/gexiv2-0.10.8.ebuild
+++ b/media-libs/gexiv2/gexiv2-0.10.8.ebuild
@@ -31,6 +31,7 @@ RDEPEND="${PYTHON_DEPS}
vala? ( $(vala_depend) )
"
DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
virtual/pkgconfig"
src_prepare() {