summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-17 15:33:27 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-17 15:33:56 +1300
commit818ffedb39f77197765b244891bcb67172147b48 (patch)
tree06df2a33c3e5aff82a691d21775f3c23030262c5
parentprofiles: drop obsolete kde-plasma/plasma-meta[crypt] mask for arm (diff)
downloadgentoo-818ffedb39f77197765b244891bcb67172147b48.tar.gz
gentoo-818ffedb39f77197765b244891bcb67172147b48.tar.bz2
gentoo-818ffedb39f77197765b244891bcb67172147b48.zip
dev-perl/Tk-CursorControl: EAPI6 + tests + fixes
- EAPI6ify - Enable tests (w/ X11) - Cease installing demos to @INC as that's the wrong place for examples - Don't install demos at all due to RT#124794, which basically makes the demo useless without the Makefile, which basically makes installing it a waste of time (for now) Bug: https://rt.cpan.org/Ticket/Display.html?id=124794 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r2.ebuild30
-rw-r--r--dev-perl/Tk-CursorControl/files/Tk-CursorControl-0.4-nodemo.patch40
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r2.ebuild b/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r2.ebuild
new file mode 100644
index 000000000000..0cb384cb448f
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DUNNIGANJ
+DIST_VERSION=0.4
+
+# https://rt.cpan.org/Ticket/Display.html?id=124794
+# DIST_EXAMPLES=( "demos/*" )
+inherit eutils perl-module virtualx
+
+DESCRIPTION="Manipulate the mouse cursor programmatically"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Tk"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4-nodemo.patch" )
+
+src_prepare() {
+ perl-module_src_prepare
+ edos2unix "${S}"/{CursorControl.pm,demos/cursor.pl}
+}
+src_test() {
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/Tk-CursorControl/files/Tk-CursorControl-0.4-nodemo.patch b/dev-perl/Tk-CursorControl/files/Tk-CursorControl-0.4-nodemo.patch
new file mode 100644
index 000000000000..386a6f0aa255
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/files/Tk-CursorControl-0.4-nodemo.patch
@@ -0,0 +1,40 @@
+From 299ab08346de3f8f670d3a50c6180bccf0402067 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 17 Mar 2018 14:52:48 +1300
+Subject: Stop installing demo's to @INC
+
+---
+ Makefile.PL | 13 +------------
+ 1 file changed, 1 insertion(+), 12 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index c229779..2503a8e 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -14,11 +14,7 @@ WriteMakefile(
+ 'CursorControl.pm' => '$(INST_LIB)/Tk/CursorControl.pm',
+ 'trans_cur.xbm' => '$(INST_LIB)/Tk/trans_cur.xbm',
+ 'trans_cur.mask' => '$(INST_LIB)/Tk/trans_cur.mask',
+- 'demos/cursor.pl' => ($] >= 5.005
+- ? '$(INST_ARCHLIB)'
+- : '$(INST_LIB)') . '/Tk/demos/widtrib/cursor.pl',
+- },
+-
++ },
+ 'PREREQ_PM' => {
+ 'Tk' => 800.015,
+ ($^O =~ /(MSWin32|cygwin)/ ? ('Win32::API' => 0.20) : ()),
+@@ -28,10 +24,3 @@ WriteMakefile(
+ 'CursorControl.pm' => '$(INST_MAN3DIR)/Tk::CursorControl.$(MAN3EXT)',
+ },
+ );
+-
+-sub MY::postamble {
+- '
+-demo :: pure_all
+- $(FULLPERL) -w -I$(SITELIBEXP)/Tk/demos/widget_lib -I$(SITEARCHEXP)/Tk/demos/widget_lib -Mblib demos/cursor.pl
+-';
+-}
+--
+2.16.2
+