summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-28 17:41:04 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-28 18:00:38 +0200
commit82ad74063afea6c189725cf551fbdec506d86fa2 (patch)
tree1142e79830a1726f7b6441a31ab463a72248fbe6
parentsys-libs/libomp: Bump to 7.0.0rc2 (diff)
downloadgentoo-82ad74063afea6c189725cf551fbdec506d86fa2.tar.gz
gentoo-82ad74063afea6c189725cf551fbdec506d86fa2.tar.bz2
gentoo-82ad74063afea6c189725cf551fbdec506d86fa2.zip
sys-devel/clang-runtime: Bump to 7.0.0rc2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-7.0.0_rc2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-7.0.0_rc2.ebuild b/sys-devel/clang-runtime/clang-runtime-7.0.0_rc2.ebuild
new file mode 100644
index 000000000000..0a2d24887e05
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-7.0.0_rc2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS=""
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"