summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-19 10:20:25 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-19 10:26:45 -0800
commit83541cb2bb029fc1770632924386f2ba5954f352 (patch)
treec137cbf97f39200a226efcb90a3d47cc857dc45f
parentsys-power/nut: drop USE=gui due to python2-only (diff)
downloadgentoo-83541cb2bb029fc1770632924386f2ba5954f352.tar.gz
gentoo-83541cb2bb029fc1770632924386f2ba5954f352.tar.bz2
gentoo-83541cb2bb029fc1770632924386f2ba5954f352.zip
media-libs/mesa: Add IUSE=+zstd
Closes: https://bugs.gentoo.org/709744 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 5bec3f52d106..4710eca2f2df 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -37,7 +37,7 @@ done
IUSE="${IUSE_VIDEO_CARDS}
+classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 libglvnd +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
- vulkan-overlay wayland +X xa xvmc"
+ vulkan-overlay wayland +X xa xvmc +zstd"
REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
@@ -128,6 +128,7 @@ RDEPEND="
>=x11-libs/libxcb-1.13:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
)
+ zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
for card in ${RADEON_CARDS}; do
RDEPEND="${RDEPEND}
@@ -482,6 +483,7 @@ multilib_src_configure() {
$(meson_use gles2)
$(meson_use libglvnd glvnd)
$(meson_use selinux)
+ $(meson_use zstd)
-Dvalgrind=$(usex valgrind auto false)
-Ddri-drivers=$(driver_list "${DRI_DRIVERS[*]}")
-Dgallium-drivers=$(driver_list "${GALLIUM_DRIVERS[*]}")